Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

"Explode Into Current View" NOT working - ArchiCAD 23 EDU

Not applicable
Hello everyone!

I have installed ArchiCAD 23 (Educational/Trial version) to my computer in order to take some online classes on how to use the software. Five lessons in, and a problem appeared: I can't explode a block into current view. It simply doesn't work.

Let me explain step by step what's going on:

1. I was provided a DWG block of a terrain.
2. As instructed, I placed it within my ArchiCAD file via File > External Content > Place External Drawing
3. Once the drawing/block was placed there, I proceeded to unlock all elements via Edit > Locking > Unlock All
4. To make sure I wouldn't miss any element from the drawing, I also went into my Layers and made them all visible.
5. Then, finally, I proceeded to right-click the drawing, go into "Explode Into Current View". Nothing happened.
6. I've tried turning off "Keep Original Elements After Exploding", and still no hits.

I have 22 days until my Trial license is revoked, but my introductory ArchiCAD course will expire in 6 days so I am kind of pressed right now.

So, if anyone's able to help me, I'd be super thankful.
Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni

Thank you for sharing the issue!

By default, in ARCHICAD 23, if you explode a drawing (either a DWG or a PDF), exploded elements will have "New" renovation status. I believe New Elements are being set to "Hide" in the Renovation Filter Options. You need to set New Elements to be visible in the current Renovation Filter in order to have elements visible after exploding. After that, you can safely delete the DWG. To find out more about Renovation Filter, please have a look at this article:

I hope this will help you with your question! Best of luck with the course, and welcome to ARCHICAD!

Best regards,

Minh Nguyen
Technical Support Engineer

Not applicable
I went to Renovation > Renovation Filter Options > Renovation Filters > 04 New Construction and set all Filters to "Show".

It seems to have solved the issue just fine!

Thank you for the help!

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!