Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Archicad snap is not precise

Jan dapond
Newcomer
Hello !
After I found that blue circle on corner which is not easy to wait all the time by the way,


But even after blue guide snap set it still works like that. It is not sitting precisely on the line as you can see, and that zoom is not too much close to blame magnification.

1 ACCEPTED SOLUTION

Solution
Karl Ottenstein
Moderator
Jan wrote:
Hello !
After I found that blue circle on corner which is not easy to wait all the time by the way,
...
But even after blue guide snap set it still works like that. It is not sitting precisely on the line as you can see, and that zoom is not too much close to blame magnification.
...
Hi,

Snap is absolutely precise, but you need to learn at least two things about ARCHICAD to appreciate it.

First, the delay is controlled by a setting in the Work Environment. See the attached screenshot and change the default 1.5 seconds down to something smaller if you wish.

Second, never attempt to snap when you are zoomed out. Everyone runs into something like your example early in learning ARCHICAD and then realizes that there was another snap point near where they held their mouse. The only way to select the desired snap point is to be reasonably zoomed in.

In your case, you may have other model elements that have a snap point at the offset spot that you illustrate. What I think is more likely is that your walls are composite walls and that all skins are not being displayed. Zoom in to that same corner and hover your mouse over the actual corner...and at the offset location to verify. Then explore your model to see why there is a snap point at the offset. 🙂

Cheers,
Karl

PS. If you have grid snap enabled (I do not recommend it) - then it will affect your ability to snap to element snap points which are 'off grid'.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6, iMac Pro

View solution in original post

9 REPLIES 9

Laszlo Nagy
Community Admin
Community Admin
Are you working very far from Project Origin? That can cause such inaccuracies.

By the way, when you are above an element Node or Edge as indicated by the smart cursor, you can press the Q key and the Snap Point or Snap Guide will be immediately placed, no need to wait.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Solution
Karl Ottenstein
Moderator
Jan wrote:
Hello !
After I found that blue circle on corner which is not easy to wait all the time by the way,
...
But even after blue guide snap set it still works like that. It is not sitting precisely on the line as you can see, and that zoom is not too much close to blame magnification.
...
Hi,

Snap is absolutely precise, but you need to learn at least two things about ARCHICAD to appreciate it.

First, the delay is controlled by a setting in the Work Environment. See the attached screenshot and change the default 1.5 seconds down to something smaller if you wish.

Second, never attempt to snap when you are zoomed out. Everyone runs into something like your example early in learning ARCHICAD and then realizes that there was another snap point near where they held their mouse. The only way to select the desired snap point is to be reasonably zoomed in.

In your case, you may have other model elements that have a snap point at the offset spot that you illustrate. What I think is more likely is that your walls are composite walls and that all skins are not being displayed. Zoom in to that same corner and hover your mouse over the actual corner...and at the offset location to verify. Then explore your model to see why there is a snap point at the offset. 🙂

Cheers,
Karl

PS. If you have grid snap enabled (I do not recommend it) - then it will affect your ability to snap to element snap points which are 'off grid'.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6, iMac Pro

View solution in original post

Hi Karl,

 

If I am working in a two-story building, first I first place all walls in the ground story then I do all reference lines to create a wall for the first story but the problem is I can't match the same line of the wall.

You can copy and paste walls from one storey to another and they will paste in the same position as the the other storey - just in the new storey with regards to height position (& they will belong to the new storey).

 

Or you can turn on your Trace & Reference and use another storey as the reference, and simply trace over where you want new walls.

 

There is no need to set up reference lines to position new walls on another storey if that is what you are doing - or maybe I misunderstand your problem.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Barry Kelly
Moderator
Karl wrote:
First, the delay is controlled by a setting in the Work Environment. See the attached screenshot and change the default 1.5 seconds down to something smaller if you wish.

And if you don't want to set a shorter time limit (because you will start getting snap guides on everything you touch), you can leave it at something like 1 second (which isn't too long to wait).
Then if you want you can hover the mouse over a node or edge and instead of waiting one second, press the ` (the tilde key just to the left of number 1) key or q key and you will get an instant guide snap.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Jan dapond
Newcomer
Hi!
I'm starting to understand some things in Archicad eventually as it has good but sometimes not obvious functionalities that I need.
LaszloNagy, Q key is very good thanks.
"Are you working very far from Project Origin? That can cause such inaccuracies."
I don't think it is far from origin, that blue circle is the point I want to snap (of course I'm magnifying before snap)


Karl Ottenstein

thanks for screen, it is really helpful.
"Second, never attempt to snap when you are zoomed out"
I snap only when zoomed, I think in my case problem is that it can't create snap circle at all on turned finish layer.
"What I think is more likely is that your walls are composite walls and that all skins are not being displayed."
I have no hidden skin there. I also have grid snap turned off.


Barry Kelly

"And if you don't want to set a shorter time limit (because you will start getting snap guides on everything you touch), you can leave it at something like 1 second (which isn't too long to wait)."

1 second is not very long but it isn't about one or half seconds, it is about a fact that even you work very fast you need to make little stop every time, which would be very annoying if it would be like that, btw tilda key does nothing , but Q is very good option yes. Thanks.

Overally there is a problem that still exists. see that image below.


At image "1" snap is good at left side of a wall , at "2" I'm trying to snap to finish layers corner but it shows no "V" sign to make blue circle, thus I think snap is inaccurate.
at "3" I'm snapping to same finish corner but now it snaps without problem.

What is the problem with second one? Which I think is the original issue of my displaced line in very first example.

Braza
Newcomer
Jan wrote:
Overally there is a problem that still exists. see that image below.
Check your Wall Closure "Dimensionable on 2d" option.

Paulo Henrique Santos, Architect
AC24_INT#3008 / I7 / 16Gb / 512Mb SSD / Windows 10

Jan dapond
Newcomer
Braza wrote:
Jan wrote:
Overally there is a problem that still exists. see that image below.
Check your Wall Closure "Dimensionable on 2d" option.
thank you Braza , that works nice but I still have little issue with wall connections , all layers here are at correct priorities and connecting well, but that little gap and line which appears and disappears randomly.
too much hassle with those walls at the beginning, that left is before connection and right one is precisely connected thin wall to that outer wall.

how to have perfectly connected wall ?

Braza
Newcomer
The problem is that the 2d view of the window wall closure is just a simple fill. It won't respond to Priority Based Components. In this case you have several workarounds.
One: Create a Patch. First select the area which you will apply the patch. Then this:

Save the patch (Which will be a 2d object embedded in your project file). Finally "Open Object" > edit the 2d symbol > Save the modifications.
Hope this helps.
Paulo Henrique Santos, Architect
AC24_INT#3008 / I7 / 16Gb / 512Mb SSD / Windows 10

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!