About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

[Archicad 23] dimensions bug


Recently my file has experienced a bug regarding dimensions placed in the view map. It is a recurring issue that happens on and off where I will open a view which has dimensions placed and they will suddenly be all over the place and appear not linked to anything and floating in space. If I update any sheets showing these views, they will also update to reflect these crazy dimensions running off the page.

Screen Shot 2022-04-27 at 3.08.53 pm.pngScreen Shot 2022-04-27 at 3.09.15 pm.png


However when i select the dimension itself, it is still tied to whatever element I placed it to. I have temporarily worked around the issue by closing the file and completely restarting my computer but this is too time consuming to continue doing. Has anyone experienced this issue and know a solution to fix.


Barry Kelly

What elements are the dimensions linked to?

Are those elements changing in any way?

I am wondering if it is anything to do with renovation filters.


It won't be partial structure display.

This affects how some elements are shown (finish, core, etc.) - some parts you might have dimensioned will no longer be there.

But that is solved by you having to re-dimension everything in each partial structure display.


But with reno filters, elements can be shown or hidden and I am wondering if this might be affecting the dimension association.

I don't know for sure, just hunting for a possible solution.



One of the forum moderators.
Versions 6.5 to 26
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Try launching Archicad and then open the file from within Archicad itself using the file open menu. You will get a tickbox option to open and repair. Select this. That often fixes glitches like this. Also make sure you haven’t drawn all your data far from the 0,0 origin. 

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 5003
macOS Ventura (13.5.2)

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!