BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Dimensions to grid not exported in module


Hi guys,


I got a typical floor moduled across the building. I dimensioned the partition setout to gridlines and walls core. The problem is that any dimension snapped to the grid won't appear on placed modules. 

Is that a limitation or did we set something wrong? i

As a note the grid and the dimensioned walls are all part of the same mod. 

See level 01 below, origin or the mod


See level 02 below,  where the mod is placed. The dimension related to the grid was not transferred. 




Vincent G

I'm having the exact same problem, I got to dimension each floor independently which is far from ideal. Any way to get this working?

Benjamin Dani



I'm very sorry to hear about the issue!
May I ask you in what version of Archicad are you noticing this problem?
In Archicad 25 and 26 I don't happen to see this error. 

Please correct my steps if you did it differently:

1. I placed a wall with insulation

2. I placed a grid using the grid tool

3. I placed three dimension points: two for both sides of the insulation and one for the grid (similar as you showed on the picture)
4. I saved this file as a module file

5. I opened a new Archicad instance and loaded the module file (first time I loaded all stories, second time only the story which had my wall in it)

6. I was able to see the dimensions both times 

Are you able to create a new file and reproduce the issue?
If yes, could you please provide me the steps?

Kind regards,

Dani Benjamin
Technical Support Engineer

Hi Dani, 


I am using AC24 7000AUS full. I followed the steps above (new file, one grid line, one wall, one dimension (auto-dim to core faces) from wall to grid). I saved the whole file as a mod and placed it into a new file. It worked fine. 


On my work files, the module system is a bit different. My first floor is moduled and placed above. Rather than working with a bunch of separate files, I saved the L01 as a view that has a specific module dedicated layer combination. I got a publisher set for mods, so whenever I operate changes on my L01 and want those changes to update across the levels I publish that view/module and update the hotlinks. It works perfectly but for dimensions. Also, I ensured that the grid layer is turned on in my module view (anything ON is moduled). 


Could the issue come from the fact that the module origin and instances are in the same file and somehow Archicad won't module the grid? I had a look in 3D and it seems that everything is placed above but the grid which would explain why the dims are broken. 



Hi Vincent,

Thank you for the clarification!

It is suspicious that the grids are not duplicated above. 
In a new file (same Archicad version and build as you are using) I was able to save the ground floor as module then place it on the first floor while having the grid duplicated. I also had my dimensions show up correctly.
I even tried to save the dimensions and the wall only (the grid was not included in this new module) and put it on the floor above: it had all the content of the module. 
I think this issue might need deeper investigation. 
I suggest reaching out to your local Graphisoft representative here for further support.
Please send them the problematic file, this detailed description and maybe a video showing the issue in detail for better understanding.

Kind regards,

Dani Benjamin
Technical Support Engineer

Learn and get certified!