Choose your top Archicad wishes!

Read more
Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Fills appearing as Black in Layouts

Anonymous
Not applicable
Hi,

I have a section drawn with some solid color fills over the top. When I place it onto a layout, all of the fills only show up as black instead of the colours they should have. Why is it doing this?

Edit: By changing it to an "empty fill" with only the background color visible, the fill has changed from black to grey, and the outline is showing as the correct colour.

Thanks.
8 REPLIES 8
Barry Kelly
Moderator
The drawings in the layouts can have a different pen set to the one used in the views.
Have a look at the drawing settings to see what pen set it is using.

Barry.
One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Anonymous
Not applicable
Thanks, Barry.

They are set as a different pen set, but the particular colours I have used are the same in both sets. Also if I change the drawing on the layout to be the same as when I am drawing the section, they still appear as black/grey.
Barry Kelly
Moderator
Are all colours coming out black in the layouts or just the fills?
If all then it could be this setting...
Barry.
One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Erwin Edel
Rockstar
Right click the placed view and pick open source view, are the fills ok there? If not, you might have set up some graphic override to display fills as black / solid.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5
Anonymous
Not applicable
Thanks for the suggestions, Barry and Erwin. I have had a look at both of these things and neither seem to help in solving the problem. The only way I have managed to get any fills to show up as a non-grayscale on the layouts, are to be changing the fill to be an Image Fill, which is not particularly useful because I don't want to be adding a huge amount of image fills to cover all the different fills in all the different colours I might need.

I also tried placing the same fill onto a plan view and putting that view onto the layout which did make the fill appear coloured as intended. It only seems to be a problem when linking views from Sections or Elevations.
Erwin Edel
Rockstar
Make sure Trace and Reference is off in the Section view when checking it, it might have the option turned on to make fills look transparant.

Try picking up the settings from the floor plan placed drawing with ALT and inserting them in to the placed section drawing with CTRL + ALT.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5
Mats_Knutsson
Advisor
I also get this occasionally in AC21. I just had internal training and out of nine people, two had this problem. They all used the same template. Everything seem correct but the views just turns black on the layout.
AC 25 SWE Full

HP Zbook Fury 15,6 G8. 32 GB RAM. Nvidia RTX A3000.
Airomin
Newcomer

 

Hello, possible solution.

 

Click the layout drawing and on the top tool bar, when drawing is selected, scroll through till you see black and white option and change it to defined by pen set, that should do it.