Choose your top Archicad wishes!

Read more
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

How do I change perspective flythrough speed on macOS / changes to customised work env


Hello, long time Archicad user here. I have started a new job and unfortunately I have to use macOS. This throws up hundreds of problems everyday. I've listed some of the most pressing issues that are preventing me from being able to work efficiently.


1.  One issue I can't resolve is the perspective fly-through speed.

For no reason the perspective fly through speed has gone to zero and I cannot edit it.

There doesn't appear to be a button shortcut which I can assign to this. I have tried various "zoom" shortcuts and assigning different buttons, on Windows this is an instant fix. On macOS it does nothing. Is there an assignable shortcut / button on macOS to control the flythrough speed?


2. Cannot assign magic wand to space bar. There seem to be a whole lot of macros on Mac which just don't work. Does anyone know why space bar can't be assigned to magic wand on Mac?


3. Escape button doesn't work half the time. This one I don't know if anyone can help me with, but the Esc key just doesn't work half the time when it should - I can't use it to close a fly through, I can't use it to cancel, I can't use it to do around half of the functions it should work with in Archicad.


4. Keyboard macros just change for no reason. I will save a customised work environment, keyboard shortcuts, go home and then the next day all my settings are stuffed around with. This seems to have something to do with macOS updates even though its not updating. I know for a fact no one is touching the computer, and I am setting the keyboard shortcuts / work environment settings correctly and saving them. When loading a file it will show the correct user preference settings loaded but these don't come into effect until I re-load the settings.


All of these issues seem to be due to having to use macOS, unfortunately I can't change this. I would in a heartbeat if I could. Does anyone have solutions / know the cause of these issues?


I was using a Mac keyboard but I have replaced it with a cheapest keyboard I could find that cost basically nothing but works 100 times better than the Mac keyboard.

Same deal with the mouse, replaced with a mouse with a scroll wheel and actual buttons.

I've tried plugging in the original Mac keyboard / mouse and these don't resolve the button issues - fly through speed, space bar, escape button, keyboard macros changing.

This shouldn't effect anything but being a Mac, plugging in head phones will probably delete my projects so it wouldn't surprise its something to do with the keyboard / mouse.


Using Archicad 25 up to date, and a Mac 27 in 5k i9.






sounds to me got hardware input problems base on the way you describe things.

In the end what is your Objective?
ArchiCAD 9 onwards

Hello Ryejuan, thanks for the info. We have 5 other computers that are all the same with the same updates and programs installed. They all also have the same problems and are using the standard Mac keyboard and mouse that came with the iMac. I have also done some testing with the customised work environments, and they also have issues with their computers changing settings that have already been saved and this is regardless of whether the computer is connected to the server.


There might be a hardware input issue, but if there is, its an issue that effects all current iMac's with latest patches for both OS and Archicad.


I had similar issues at a previous workplace, and another before that, and another before that, in fact I have never encountered an install of Archicad on macOS which actually works correctly; there is always an issue like the ones I have posted or something worse.

have you tried updating Archicad to the latest hotfix?

In the end what is your Objective?
ArchiCAD 9 onwards

It's been a month, I've spent countless hours trying to fix this and read many forum topics / posts.


I am convinced that Archicad on Mac is just a total waste of time, and Mac's in general are a total waste of time.


I have tried updating, reinstalling and different versions of Archicad.

3d explore just doesn't work on Mac, which is dumb in a drafting program where the main selling point is designing, editing and viewing in 3d.

I understand this is probably an issue on Apple's side rather than Graphisoft, but can Graphisoft send a message to Apple that their rubbish OS has had this problem for 10+ years judging from forum posts.


@PClarke There is a huge percentage of us here who are on Macs and who have never had any major issues that you claim have been going on for years.  If you'd like to be productive here, please list specific things that you think don't work on a Mac but that work on Windows.  Ideally, post each topic as a new thread so that it can get the attention it deserves - and help other/future users, rather than a post that lists multiple things... making marking any response as a 'solution' unlikely.  Be specific so whatever you're having a problem with can be reproduced easily.  Thanks.


One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Karl Ottenstein

Fly through generation works as it has for over 20 years, and I'm finding no problems at all on a Mac.


That said, most people have generated their fly throughs in other software such as Artlantis, Twinmotion, etc because the set-up within Archicad is so awkward.


To get the time you want, you cannot simply enter time in seconds.  It is a combination of frames and a frame rate.  Your frame rate, ideally, would match your localized video standard such as 25 FPS for PAL or 30 FPS for NTSC so that you can merge your fly through with 'normal' video and have it all render reasonably.


It's not necessary of course.  But, you want at least a frame rate of 25 in my opinion for the video to have smooth motion.  Thus, you will need 25 frames to be generated for every second desired.


The camera path dialog where you assemble your cameras looks like this:

Screen Shot 2022-05-25 at 8.18.24 PM.jpg


This lets you specify how many frames are generated on the path between the cameras placed in plan view.  And, this is where things get awkward/tricky in Archicad because two cameras might be 5 feet apart and the next camera might be 100 feet away.  If all three cameras are on the same path and have the same frame count for the in-between frames... then if the camera that dollies over 100' presents a pleasant motion - then the one that dollies over only 5 feet will feel tediously, awfully slow.

So, path management is just part of the issue here (vs other software).  The functionality here has not changed in 25 years that I can remember.


The generate fly through dialog:


Screen Shot 2022-05-25 at 8.26.16 PM.jpg

is where you specify the frame rate for the frames that you entered in the path dialog... and so total frames is divided by the frame rate to get the seconds for the resulting animation.  You can of course change the frame rate to make things longer or shorter... but without sufficient frames per second, the animation will be jerky instead of smooth... so it is generally best to use a standard frame rate like PAL, NTSC, or in the screenshot the default is 'cinema' of 24 fps....  Then if you want things longer or shorter, specify more or fewer frames in the path dialog.


It all works the way it always has for me.


One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Karl Ottenstein

On your issue #2 - all of us on Macs have spacebar for magic wand.  It's hard-coded as far as I know... (I don't think spacebar is something you can change in the Work Environment?).  So, if it isn't working for you, try an out of box default work environment.  If it still doesn't work, the perhaps something else on your computer is intercepting the space bar.


One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Karl Ottenstein

Issue #3 - ESC / escape key always works for me.  What keyboard are you using and or do you have a 3rd party keyboard macro app of some kind running?

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Karl Ottenstein

#4. Archicad does not have keyboard macros.  It has shortcuts only.  Your Work Environment schemes must be saved, and each scheme that comprises the WE must be saved with a name... then a WE is saved which lists all of those named settings.  Once saved properly, when you launch, as long as you don't select a different WE, you should get the last one used and all of your shortcuts should be the same as always.


My guess is you haven't saved/named each of your schemes and your total WE and/or you have a 3rd party keyboard driver or macro utility running.

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!