Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Level Dimension hidden but still selectable on plan?

MinhNguyen
Advocate

Hi everyone, one of our team members pointed out a very weird behavior in Archicad that we would never think of: with Labels and Level Dimensions, you have the option to "Hide with associated element". Logically, once it's hidden, you shouldn't be able to select the element, right? Not with Level Dimensions. Here is how to reproduce it:

 

With everything visible, on floorplan I have 1 slab, 1 associative level dimension, 1 label, and 1 static level dimension.

MinhNguyen_0-1702024796339.png

 

Now with only the slab hidden using layer (layer for annotation is still visible), pressing Ctrl + A gives me 2 elements selected:

MinhNguyen_1-1702024868110.png

 

To make sure that I don't select anything else, using Find&Select will give me the same result - the hidden level dimension is selected.

MinhNguyen_2-1702024927808.png

 

Same behavior in AC21, 24 and 26, which makes me think it's not a bug. But it's against Archicad's logic and I can't find any documentation/discussion regarding this. Could someone help me to explain this?

BIM Manager
DKO Architecture - HCMC

1 ACCEPTED SOLUTION
4 REPLIES 4
Barry Kelly
Moderator

Seems to be because the level dimensions are in the same layer.

The slab layer is turned off, but the dimension layer is not.

However the dimension set to hide with element disappears (as expected), so it is just not visible, but it is still there in the same layer as the other dimension.

Archicad can still select it - although you see nothing selected - just the info that it is selected.

And it is indeed selected, because if you make a change (font colour) and turn the slab back on, the associated dimension has also changed.

 

If the dimension is in the slab layer, then when the slab layer is turned off the dimension will not be selected.

But of course that does not help if you want to turn the dimensions off and still show the slab.

 

I say bug.

Because, if you think you can select all dimensions not associated to an element by hiding the element layer, and then deleting ALL dimensions - surprise, they have all gone.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry, 

Agree, this is what I thought as well. But the strange part is: as you can see in my example, I dropped a label there for a purpose: its layer is visible, it's hidden with the slab similar to the level dimension, but it's not selectable when the slab's layer is turned off. It could be a bug with the level dimension, however no one noticed it until now, so could there be a reason that I didn't know?

BIM Manager
DKO Architecture - HCMC

Solution

I didn't try with the label, but you are correct, a hidden label does not get selected.

So definitely a bug I say.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Time for a support email then. Thanks Barry!

BIM Manager
DKO Architecture - HCMC

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!