Installation & update
About program installation and update, hardware, operating systems, setup, etc.

ArchiCad27 won't download

bubbly
Participant

I want to download the Archicad27 version of my student license, or any other version of Archicad but am faced with a problem. For a second a screen appears saying something like "thank you for downloading", Then it changes into 

Our services aren't available right now

We're working to restore all services as soon as possible. Please check back soon.

 

I already tried it various times on different days.

Does someone know the problem?

I work on MacBook Pro with macOS 13.4.1 and have Archicad23, 24 and 25 installed.

3 REPLIES 3
ozco
Newcomer

Have you find a solution??

Maybe try a different browser?

 

I assume you are going through the MyArchicad website.

Once you have logged in, at the top there is a 'Get in Touch' link.

I would use that.

 

Or you can download any version of Archicad that you want from the main Graphisoft website...

https://graphisoft.com/resources-and-support/downloads?section=product&localization=INT&product=arch...

 

But you will need a license still to use it.

And student licenses you apply for through MyArchicad I believe.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
rculveraia
Newcomer

You need to disable content blockers and pop-up windows for Graphisoft websites

This solved the problem for me.

 

EDIT.

I have removed the link to the download and changed it to "Graphisoft websites", as the link was for a particular version for a particular operating system only.

The link I have in my earlier post will allow the user to choose whatever version and OS that they want.

Barry.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!