Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Archicad 19 info box lag

Not applicable
I started having problems with my info box for several months now, and I couldn't figure out the cause of the lag. Back then, my computer ran windows 10 (upgraded from 8.1 with the suggested upgrade from microsoft).
I read on forums that others had this problem too, but none of their suggested fixes worked in my case.
Basically, when I select a tool, the info box takes like 1 second to fully load and it does that by loading each row of information at a time. It's not an instant load, as it's supposed to. While this happend, the Archicad is in a state of not working, so it affects my productivity a lot.
I'm working in an office, we have over 10 pc's (different specs for each one), all running Archicad 19. Only 2 of these have this problem. Mine and a co-workers. So I tried what anyone would do: I cleaned my pc with ccleaner, defragmented the disk, tried a couple of fixes from other forums, reinstalled archicad. Nothing worked.
So I contacted our tech guy and asked him to do some more cleaning and to look for bugs. We ended up deciding it was best to try and install windows from 0.
My computer has a windows 8 licence, intel core i5-3450 CPU, 3,10 GHz, 3,50 GHz, 16 GB RAM, x64-based processor, AMD Radeon R7 360 Series.
After reinstalling w8, everything was ok, back to normal.
After attempting to install DWG Trueview, I found out it isn't supported on windows 8. Since I need this program, I upgraded the windows 8 to 8.1, basically because every morning it appeared on my screen: upgrade now to windows 8.1, and everybody on every forum I ever visited said: do not stay on windows 8, upgrade it to 8.1.
Now, the problem is back.

What can I do to fix this?
Is it an incompatibility with some drivers?
When I did the update to 8.1, the display adapter switched to some windows default and I had to reinstall the amd radeon driver by myself. I feel as if this is not the only issue that could have appeared after the update.
Any suggestions?
Not applicable

I'm having the same exact problems! I'm using Archicad SE 2014. I just upgrated my hardware and re-installed Windows so I don't belive it's a problem related to hardware.

For me works, if I hide the information box from the screen but that's something I don't want to do because it helps me with my work.

Could someone please reply to this problem. It's really annoying and surely effects productivity!
Not applicable

Have someone had these kind of problems? Still having mine.
Eduardo Rolon
Usually GS only keeps updated the current version of AC and the previous one, your start version is almost 6 years old so I don't think that GS will fix that issue. Regardless if the current Windows version will let you I would try to run AC in "Compatibility Mode" that matches the 6 year old version of windows. The other option is to run it in a virtual machine.

The correct solution is to upgrade to the newest version and keep it for the next 6 years.
Eduardo Rolón AIA NCARB
AC27 US/INT -> AC08

Macbook Pro M1 Max 64GB ram, OS X 10.XX latest
another Moderator

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!