Got a minute? We appreciate your feedback:

Graphisoft Learn survey
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Cant sign in and download ArchiCAD on Website




I have a problem with sign in and accessing and also downloading Trial version.


When I try to log in on the page I got an error like this:



If I try to download the trial version, the site asks me to sign in but when I try to sign in nothing happens instead I get an error in the console:


But on the page I can see my account and manage it so there I have no problem.


I've already checked my hosts file and reset it. Tried 3 different browsers, chrome edge firefox and also I tried on my iPhone.


Much appreciate every answer!


Karl Ottenstein

This is an issue with the new Graphisoft ID (GSID) server functionality implemented on June 10.  It is solved in all cases that I've seen by completely clearing all cache and cookies associated with any * domain and then trying again.


The Learn portal seems to be the most affected, but clearing cache and cookies gets it functioning again.


One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.2, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Thank you! It solved the download part, but I still can't login to the  it still gives me the unexpected error message


I tried deleting not only the cache and cookies but all of my browser's cache and cookies but I still can't access the learn page

I tried now on my other computer, clearing all the browser cache before doing anything and still not working

I've read of others being successful with Icognito Mode in Chrome or Firefox after deleting cache and cookies.  Try that?


Please understand this is not normal and not how things are supposed to work.  But, something about changes to the Graphisoft ID process on June 10 is impacting Graphisoft sites but especially the Learn portal.


(Personally, I've had cases where I got an error page, and then tried to go back to the original URL and it showed that I was logged in and everything seemed normal.)

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.2, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

I tried incognito mode after deleting cache and cookies but still no success...

I would contact your local Archicad support and see what they say.



One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11


Dear Kropeey,

Please reach out to us at and we will look into the issue.


Thank you!

Akos Karoczkai

Customer Success, Graphisoft

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!