Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Serious lagging

Not applicable
Archicad is lagging a lot on a recent project which is not that big. i checked the task manager and the only thing that seems to be working really hard is the ethernet connection. i guess Archicad is trying to read something from our server?
other than that, its using 2gb of ram and the cpu or gpu is not stressed at all.
The only thing i can think of that is producing this lag are two or three models that were imported so the polygon count might be a bit high? the models are not complicated..

its really annoying though because every 3d software out there is capable of handling millions of polygons but when you import 3 chairs or tables in Archicad its starting to lag.
i dont know if i have a question, but maybe someone can explain this lag
Hello papsphilip,

Did you check ?
- SEO with mesh
- Object with a lot of polygons
- MVD about railing tool and curtain wall
Christophe - FRANCE
Archicad Designer and Teacher
Archicad 15 to 27 FRA FULL

OS 11.6 Big Sur - MacBook Pro 2017 - 16Go RAM
"Quality is never an accident ; it's always the result of an intelligent effort" John Ruskin
Not applicable
i had a similar problem, with a problem object,
it was suggested to me to convet imported objects to morphs. At the time I didnt get a chance to try the fix, I just deleted the object.
Laszlo Nagy
Community Admin
Community Admin
Very high number of polygons can definitely cause slowness so that is one area worth looking into more thoroughly. You should use the Polycount Tool to figure out the exact number of polygons:

It is part of the Goodies package which can be downloaded from here:
Loving Archicad since 1995 - Find Archicad Tips at
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Not applicable
I'm having a similar problem - a project file is starting to run slowly. I've tried using the PolyCount tool, and I'm able to see the offending object, but I'm not able to change the LOD (Level of Detail). I've added the object (a tub I downloaded from mfr - Victoria and Albert) to our office's library, still no luck. Also tried opening the objects GSM settings using the File\Libraries and Objects\Open Object command to open it for editing (CTRL+SHIFT+O) - no luck.

I've attached a screenshot of what I'm seeing in PolyCount.

Thanks all!

Barry Kelly
I wouldn't say that is an exceptionally large object - bigger than most but not massive.
If you delete the object does the responsiveness come back?
Or if you start a new file and add the tub, does it slow down?

This will help you to determine if that object is indeed the problem or not.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11