cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

SEO won't subtract with upward extrusion. But downward yes!

Robert Nichols
Advocate

I'm trying to trim walls with a GDL object I made, which contains a single EXTRUDE object, which creates a somewhat irregular roof. The walls pass through the custom roof object, but for some reason I cannot get SEO operation SUBTRACT WITH UPWARD EXTRUSION to make any changes in the wall. Simple SUBTRACT and SUBTRACT WITH DOWNWARD EXTRUSION both work as expected. I've never seen behavior like this and I use SEO and my own GDL quite often. 

 

Anyone seen this before?

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13
5 REPLIES 5
Laszlo Nagy
Community Admin
Community Admin

Is the Object really solid? If you cut a Section through it, does it display a Cut Fill or is it hollow? Only solid bodies work in SEOs.

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27

Good question. Perhaps I used a mask value that didn't make it solid?? I will open project and check. Oh but is was working properly with simple subtraction or downward extrusion. Just not upward extrusion. But I will open project and cut through intended operator. Also check mask value in GDL. Thanks.

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13
Robert Nichols
Advocate

This one is still driving me crazy. The subtracting object (GDL lib part) is definitely solid, and as mentioned above successfully subtracts from target using either SUBTRACT or SUBTRACT WITH DOWNWARD EXTRUSION. But, SUBTRACT WITH UPWARD EXTRUSION has no effect on target element (wall). The GDL code is short and simple. I've but a simple BRICK in the code, replacing the EXTRUDE object to see if that made a difference, but no.

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13
DGSketcher
Legend

I do recall having some issues in AC23 with SEO operations, in my case complex profiles were leaving objects uncut. Probably a silly question, but do you have the latest AC23 version loaded. Can you test your object in a different version of AC?

Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)

Doh! I need to update my profile info. I'm running the current update to v25.

 

Thanks anyway.

 

(ed. sig now reflects proper equipment)

Mac Studio, 32gb ram, ArchiCAD v26 (Apple Silicon) MacOS 13