BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Parametric design
About Rhino & Grasshopper and PARAM-O.

Archicad 25 Grasshopper Connection Crashing

hpattullo
Participant

Upgraded to AC25 today (along with the AC25 update for the Grasshopper connection) and found that my Archicad crashes every time I try to enable the link. As soon as the "receiving incoming API" dialogue comes up my program crashes, no matter what Archicad file and what Grasshopper file I am trying to connect. Have tried reinstalling Archicad, the Grasshopper link, and Rhino 6 with no luck. I had been using this feature for the past year on multiple projects with Rhino6/AC24 without ever encountering this issue.

 

Has anybody else experienced this and, more importantly, found a fix for it? 

 

Error code: AC25-2022-01-04-00-08-18-4110

15 REPLIES 15

Hi Patrick,

 

Thank you for the update!

When Archicad crashes, a Bug Reporter window should appear. After successfully sending a detailed bug report, the window should give you a bugID. I suggest sending this bugID along with the simplified Archicad and Grasshopper file to the local support team for further investigation, as it may help to reveal what triggered the problem.

 

Thank you very much!

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Mario Sacco
Expert

I have a similar Issue. Bug: AC25-2022-06-29-08-29-00-9339
Archicad 25 - 

Rhino 7.19

Connection 4010

MacBook Pro - Mac M1 MAX - Monterey 12.2

Everything wos working fine yesterday using also the renaiming of the file "com.mcneel.rhinoceros.7.plist" to: "com.mcneel.rhinoceros.plist" as explaned at this post: https://community.Graphisoft.com/t5/Design-forum/Grasshopper-Archicad-Live-Connection-not-working-on...

I used the connection without problem for months.

 

Yesterday I made a test for check the functionality of an object connected to GH on AC24; I uninstalled the connection on AC25 and installed on AC 24. Everything worked fine. Then I uninstalled the connection on AC24 and reinstalled on AC25. From there The connection was estabilished but everythink I tried to create or to connect shapes creates an AC crash.

 

I tryed to uninstall completly every AC versions on the computer and installed a new one AC25 updated; I updated Rhino to the last version. But nothing has changed and the crash continues without any differents.

 

I think there is same old file somewhere in a cache that create problems.

 

Please, help me.

 

MacBook M1 Max 64GB- OS X 12.2.1 - Archicad 27
https://www.archiradar.it/en/
Mario Sacco
Expert

I have a similar Issue. Bug report: AC25-2022-06-29-08-29-00-9339I think is 

AC 25 5010

Rhinocersos 7.19

Connection 4100

MacBook pro M1 MAx 

Until yesterday AC25 worked fine for months using also the renaming of the file com.mcneel.rhinoceros.plist.

Yesterday I made a test on AC 24. I uninstalled the connection from AC 25 and installed on AC 24. Everything worked fine. Then I uninstalled the connection in AC24 an installed again it in AC25; from there The connection is estabilished but any shape I do bring the computer in crash.

 

It seems a problem of some old file in chace.

 

Please help me.

 

Mario

MacBook M1 Max 64GB- OS X 12.2.1 - Archicad 27
https://www.archiradar.it/en/

Hello Minh, is there any update on this issue? it is going on six months without any resolution.  This Archicad-grasshopper connection was a major reason I chose to dedicate the time and energy to learn and use this platform.  Thank you for your time on the matter.

Hello,

 

Thank you very much for the question!

 

If you're asking about the original defect DEF-7604 (a composite wall containing a migrated door being transferred to Grasshopper), the good news is that the defect will be fixed in Archicad 25 Update 4.

 

But to better understand the situation, I encourage you to reach out to the local support, with the bugID generated from the crash and the steps to reproduce the issue. With that, they will be able to thoroughly investigate the issue or forward it to the developers if needed.

 

Thank you for your understanding! Please let me know if you have any further questions!

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Klodi
Participant

i have the same issue. i see the latest post is two months old.  hope there there is a solution on this.

I'm trying on both Archicad 25 and 26. i can connect on. arch 25 but crashes when i use Archicad tools. Arch26,  it doesn't connect.

any suggestions

Learn and get certified!