Got a minute? We appreciate your feedback:

Graphisoft Learn survey
Teamwork & BIMcloud
About Teamwork, BIMcloud, BIMcloud Basic, BIMcloud Software as a Service, network settings, etc.

Bimcloud not accessible on Mac


The bimcloud server is not accessible, due to insecure http connection. This only occurs on MacOS (Venture 13.6) when connecting through Archicad, while on Windows and access through the browser works fine.


To me this looks like a MacOS setting issue (but I am not sure) and I have no idea how to solve it.


error message.png


I had a similar issue where strangely I couldn’t access the BIMcloud when I was on the internal network but could when I connected from home through VPN. I had to open the BIMcloud port on our router and then it worked. Almost like the connection to the Server goes out of the building and back in through the router instead of direct through the internal network. The domain nor the IP address worked. 

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 5003
macOS Ventura (13.5.2)


I have definitely seen this. unfortunately, this is something I've always left to the IT guys to fix. Something about port forwarding or firewalls or whatever... networking jargon isn't my thing

BIM solutions and trouble shooting (self proclaimed) expert. Using Archicad 26 5002 US on Mac OS 11.5.2

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!