BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI Visualizer Technical questions

Illes Papp
Graphisoft
Graphisoft

We know that taking part in an experiment can be challenging from time to time. Do you have issues with installing or running the Archicad AI Visualizer Add-on? This is your place to ask your questions and initiate discussion with others about technical difficulties you may experience while trying to install or run the experimental add-on, or generate images.

Illés Papp
GRAPHISOFT Senior Product Manager
128 REPLIES 128

Hi Sindre,

 

Thank you for the question.

 

The AI Visualizer Add-on does not run on Intel Macs. 

You can install Stable Diffusion server ('sd.webui' folder) on an Apple Silicon device and specify the address of this server in the AI Visualiser UI on your Intel Mac. The Intel device will send requests to the Apple Silicon one (set as the server) and you'll get the result in Archicad. In order to make this work the mentioned folder should be added to Archicad27/Add-Ons/Extras folder on the Intel Mac.

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

thanks for you reply, it worked!! 

Norbert,

thanks for your response. after replacing .json template I got same result. have sent to NA support team.

Hi Linn,

 

Please contact your local support and we will investigate this issue. From your description, it seems that the NVIDIA 1080 is not powerful enough to generate the image and after 10 minutes it times out. 

 

Thanks,

Norbert Kucsma

Technical Support Engineer

David WC
Participant

Hi I got this error in a 16 GB M1 pro  

Screen Shot 2023-11-23 at 8.47.08 AM.png

message...

otabekimamov
Participant

otabekimamov_1-1700792831138.png

Hi, what i`m doing wrong?

Hi David WC,

 

Thanks for the question.

Did you start the AI Engine in High Vram or in low Vram mode?

I suspect in HighVram, please try the add-on in low Vram.
On the AI Visulaizer UI:
- stop the engine (the button next to the 'Start AI Engine') and wait a minute

- uncheck the 'Start in High Vram mode' checkbox

- Start AI Engine (and wait for it to start)

- generate a picture

 

In case it still fails, please contact your local support and share the Terminal window output (Shell, Export text as...) as well. 

 

Thank you,

 

Norbert Kucsma

Technical Support Engineer

Hi otabekimamov,

 

It seems like your device doesn't not have a GPU or has an incompatible GPU. Please note that for now NVIDIA and Apple Silicon chips are supported only. 

If you have a compatible graphics card please contact your local support with your system specs and the Command Prompt (select all, copy-paste) window output. 

 

Thanks,

Norbert Kucsma

Technical Support Engineer

@Nor 
Finally, I managed to generate an image.
However, this was only after disabling HighVRAM - even though my hardware is within the specs.

Secondly, I hardly think that contacting your local support is the right move in this case. We are dealing with an experimental solution and fairly early in its development - this is not something that local support should deal with - this should be handled within GSHQ. Passing it off to local support would only make troubleshooting and development more difficult.

i will keep playing and see if anything else looks weird.

Erik Bjornhage : SwedishChef, ETTELVA Arkitekter, Gothenburg, Sweden
Architect : Digital Development : Graphisoft Cert. BIM-Manager
ETTELVA Arkitekter : Eriks LinkedIn
DELL Precision 5570; i7-12700H; 64 GB; RTX A2000 [8GB] : AC12 - future

Hello Joel, did you find any solution? Today I installed the plugin and I had the same problem...


image.png

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!