Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

IFC geometry problem after export

Karol Argasinski
Newcomer
Dear all,

I really don't know what is happening. After export to IFC, model looks horrible. It is not only in Revit, but also IFC viewer (i.e. BIMVision). It works only in BIMcollab.

Fascinating stuff
OPENBIM does works!
------------------------------------------
Currently: ArchiCAD 22/23/24
AMD Ryzen 7 3700X
32GB RAM
GeForce RTX 2070
Windows 10 Pro
------------------------------------------
http://www.bimfaktoria.pl/
8 REPLIES 8

Are you modelling very far from the project origin? That might cause issues. If you need it to be on world coordinates, there's an object to identify the position of your project.

Which IFC export settings are you using? What is the purpose/application of the file? BREP will yield the best model accuracy, but might not give the best data set and so on.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Karol Argasinski
Newcomer
Erwin wrote:
Are you modelling very far from the project origin? That might cause issues. If you need it to be on world coordinates, there's an object to identify the position of your project.

It is little bit far (this file is .mod to mother-file with terrain and so on). It has many phases/buildings so all .mod files has xyz point from mother-file. I use geodesy point object from AC Library to show 0,0,0.
I also checked with file which project zero I have changed for something in the building (so the zero is where the model is. The same result.


Which IFC export settings are you using? What is the purpose/application of the file? BREP will yield the best model accuracy, but might not give the best data set and so on.
I used three of them to check: Revit Structural, Complete geometry (BREP) and standard one, without any changes. Normally I would do mine, but that was just for testing purpose.
I got IFC from structural engineer from Revit and his file works pretty well.
OPENBIM does works!
------------------------------------------
Currently: ArchiCAD 22/23/24
AMD Ryzen 7 3700X
32GB RAM
GeForce RTX 2070
Windows 10 Pro
------------------------------------------
http://www.bimfaktoria.pl/

I use Trimble Connect (before that Tekla Bimsight) as my '3rd party test' program for IFC exports. Maybe see what results you get there.

Have you tried opening the exported IFC in archicad?

Have you tried re-booting computer?

Our local template IFC export presets are pretty robust, I've not had anything weird happen with those. But we keep our grid lines bottom left corner intersection at project origin always for all projects and use the Survey Point object to link it to world coordinates.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Karol,

Thank you for sharing the issue and I am sorry about it!

After looking at the pictures, my first thought is that the project might be located far from origin, or there are some elements that are placed far from each other (and they are placed in hidden layers). Here is the troubleshooting guide for this issue:
https://helpcenter.graphisoft.com/knowledgebase/25447/

Additionally, I would like to make sure all complex profiles and fills are working correctly, meaning none of them has corrupted geometry or placed with their origin far from the project (especially with fills).

After this, if you still cannot find out what is causing the issue, maybe it's worth forwarding the file to us for a deeper investigation.

Let me know the result of the above test!

Thank you very much!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Karol Argasinski
Newcomer
mnguyen wrote:
Hi Karol,

Thank you for sharing the issue and I am sorry about it!

After looking at the pictures, my first thought is that the project might be located far from origin, or there are some elements that are placed far from each other (and they are placed in hidden layers). Here is the troubleshooting guide for this issue:
https://helpcenter.graphisoft.com/knowledgebase/25447/

Additionally, I would like to make sure all complex profiles and fills are working correctly, meaning none of them has corrupted geometry or placed with their origin far from the project (especially with fills).

After this, if you still cannot find out what is causing the issue, maybe it's worth forwarding the file to us for a deeper investigation.

Let me know the result of the above test!

Thank you very much!

Best regards,
Minh
Hi Minh,

I succesfully moved building to center and now export works. But for me situation is more problematic due to the fact:

- FILE STRUCTURE -
1. So, I have one center file, which has "that" bad origin. It happened due to the fact, that DWG map has it own coordinates to which we need to stick to.
2. From that file, I made three copies and prepared every file for designer (there are 6 buildings, 2 per designer with different zero levels - it appears to be the best method.
3. Mother file contains only Terrain and maps, so my question is :

How can I made this process better? Should I change this zero for every module, and then just move it for the sake of the module?

Kind regards,
Karol
OPENBIM does works!
------------------------------------------
Currently: ArchiCAD 22/23/24
AMD Ryzen 7 3700X
32GB RAM
GeForce RTX 2070
Windows 10 Pro
------------------------------------------
http://www.bimfaktoria.pl/

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Karol,

I made a small mock-up to demonstrate what you described, hopefully I got it right:
- 1 host file contains the terrain
- Copies with different Level 0: I made 2 copies, then set level 0 of each of them to +1.00 and +2.00 respectively.
- Hotlinked both copies into the main file.

When I place the copies as modules into the file, I matched the Level 0 story of the module to the host file. The Elements' Elevation is set to "Keep Elevation as in Story Structure of Hotlink Source"

Here is the result:


I would say, in 3D, it looks correct, but for documentation, it might get messy, as the level of the host and modules are not 100% match to one another.

I would like to understand better what you mean by: "Should I change this zero for every module, and then just move it for the sake of the module?"

Does it relate to the DWG coordinate you mentioned?

Thank you very much!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Karol Argasinski
Newcomer
Hi!

Thank you for response.

-1 host file cointas the terrain - from this file also, we get to import all .dwg's - (this file is monstly for terrain purpose and to provide correct IFC division and hierarchy between all files.
-Hotlinks with different Level 0: I have three different files, and yes, they have different 0 level height. In those files 2D documentation is managed (floorplans/sections/elevations/details for each of the module).
-They are all hotlinked to host file.

It works fine and linking was successful, but right now there is another problem. I managed to export IFCs with a good results, but now all of the files are messy in ARCHICAD (see attachment). It is strange because all of them are close to 0,0, coordinate point in ARCHICAD. It is possible to work in 2D, but very difficult to work in 3D (corrupted geometry look and so on).

I can share file if you want.

Best,
Karol
OPENBIM does works!
------------------------------------------
Currently: ArchiCAD 22/23/24
AMD Ryzen 7 3700X
32GB RAM
GeForce RTX 2070
Windows 10 Pro
------------------------------------------
http://www.bimfaktoria.pl/

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Karol,

This still looks like a far from origin issue to me. Although nothing is far from origin, there might be some hidden elements that are placed far from each other.

I have sent you a link via Private Message where you can drop the file in for further investigation.

Looking forward to hearing from you soon!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!