Collaborate forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Schedule showing beam twice

Bethany_C
Contributor
Hello all,

I'm running into a problem where a few beams are showing up twice in my beam schedule because they seem to have multiple ID's. Under "Classification and Properties" it has the correct label. But under "Segment" it has an incorrect one. I did not select a multi-segment beam. It's one segment, but with a separate IDs. When I click on the "select in floorplan" button for both entries, it leads me to the same beam.... How do I fix this so that it only shows up once?

Is this a glitch in the system or am I missing something?
Thanks,
B
4 REPLIES 4

Barry Kelly
Moderator
In your schedule criteria you need to add a criteria for
… element type IS beam segment … if you want to schedule the beam segments.
… element type IS NOT beam segment … if you want to schedule the entire beam.

Otherwise you will have both (segments and the entire beam) listed at the same time - doubling your quantities..

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Bethany_C
Contributor
Hi Barry,

Ok I just tried that, but the duplicates are still showing up.

My criteria was:
Element Type is Beam [and]
Element Type is not Beam Segment

-Bethany

Bethany_C
Contributor
Update: I put in the criteria in a different order and it worked! Thanks for your help Barry.

- Bethany

Barry Kelly
Moderator
You will only need one and not the other.

'Is Beam' and 'Is Not beam Segment' should actually mean the same thing.

So if you want to schedule the entire beam as one element, use one of the above.

However if you have different beam segments then you will probably want to use 'Is Beam Segment'.



But the problem you have in your settings is the layers.
Because you want ...

layer is A - Beams - Structural 3D
OR
layer is A - beams - Decorative & Structural 3D

You need to put these in brackets so they act as one group of options in relation to the AND above it.
Any time you use OR, put them in brackets.

Otherwise it might do something like find anything that is a beam AND is in the structure 3D layer OR anything else that is in the decoration and structural 3D layer.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!