Choose your top Archicad wishes!

Read more
Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

Sketch-Up to ArchiCAD

griggadee
Contributor
Hi Folks,

Could anybody please tell me the best way to import a Sketch-Up model into ArchiCAD, without it becoming an object? Essentially, I want the walls to become wall elements, the floors to become slab elements etc. and I would like to be able to navigate between each floor plan.

Thanks!
Paul Griggs BSc (Hons) MCIAT MCIOB
Chartered Architectural Technologist
AC23, i5 3570K Processor, 16gb RAM, NVidia 570GTX Graphics Card, 250gb SSD Drive
10 REPLIES 10
TMA_80
Enthusiast
There used to be a plugin that do this job for ArchiCAD v12 and earlier versions.
Search for archicad12, install the skethup plugin ( This will be more an automated process and take some time though to translate) .

http://www.graphisoft.com/downloads/addons/sketchup/su_plugin_download.html

(it is good that GS has kept the link in the Webpage)
AC12_20 |Win10_64bit|
griggadee
Contributor
Hi TMA_80,

Thanks for the suggestion. Unfortunately, this hasn't solved the problem though. It seems that the Sketch-Up plugin has been integrated into ArchiCAD since version 17. I am running ArchiCAD 18 and so I assume it is already built-in.

I just need some guidance on how to use it, or to do it in some other way.

Any other suggestions folks?

Thanks
Paul Griggs BSc (Hons) MCIAT MCIOB
Chartered Architectural Technologist
AC23, i5 3570K Processor, 16gb RAM, NVidia 570GTX Graphics Card, 250gb SSD Drive
Laszlo Nagy
Community Admin
Community Admin
Your best bet may be to classify the objects properly in SketchUp, then export them as IFC, then import the IFC into ARCHICAD.
As far as I know, the latest SketchUp version can now export IFC as well as import it.
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
griggadee
Contributor
Thanks Laszlo. I'll try that.
Paul Griggs BSc (Hons) MCIAT MCIOB
Chartered Architectural Technologist
AC23, i5 3570K Processor, 16gb RAM, NVidia 570GTX Graphics Card, 250gb SSD Drive
TMA_80
Enthusiast
the Lazlo solution maybe more effecient .

But I hadn't given up 😉 so my last suggestion: what if you download one of these versions,( Archicad10for instance)
http://www.graphisoft.com/downloads/fileconverter.html
install the adpatedsketchup plugin ( in the earlier post link)

It's may worth a try ?
AC12_20 |Win10_64bit|
griggadee
Contributor
Thanks TMA_80.

I start on the project on Monday and so I'll give your suggestion a try then and see if it works. I sense that I'll need to try a number of different approaches and maybe even combine one or two before I find a solution.

I'll keep you updated.

Thanks again!
Paul Griggs BSc (Hons) MCIAT MCIOB
Chartered Architectural Technologist
AC23, i5 3570K Processor, 16gb RAM, NVidia 570GTX Graphics Card, 250gb SSD Drive
Anonymous
Not applicable
I'm using ArchiCAD v17 on a Mac and am attempting to import an skp file. I have accomplished it before on other projects. What occurs after File Special>Merge>, select the skp file, settings, it imports as a little green dot on the floor plan. Selecting it to convert to morph does nothing. This the second time out of two attempts to import a sketchup file with this result. Does anyone have a hint? Thanks.
DGSketcher
Legend
You may need to save the skp file as v8. I don't think AC likes the more recent versions... I had a pop up warning about this earlier today.
Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)
Anonymous
Not applicable
Thanks for the suggestion. Tried it; saved as v8 and the skp file came in as an object. The attempt to convert it to morph resulted in no morph being created. The file comes in as a green dot identified as an object. I saved it as v7 just to make sure with the same result.