Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Hotlinked stairs in multistory module not showing correctly

PVBergkrantz
Enthusiast
Hello. I have a project with multiple mutli-story buildings hotlinked into one file. The story height varies within these buildings, so they are all set to "Keep elevation as in Story Structure of Hotlink Source", which works pretty well, they all look the way they're supposed to and changes in story height within the modules update as it should.

I also have staircases in these modules, and while they keep their correct appearance and height in 3d, they obviously lose the link to the stories, not a big deal though. However in order to keep their correct position in the world they all get offsets from stories (of the file they're hotlinked into), some stairs being positioned 5 meters above, some below etc., this causes them to be above or below the cutting line for the stories and consequently gives them dashed lines or other weird appearances on the plans.

This might be too much to ask to work perfectly but I thought that maybe someone else might have struggled with this and have some ideas or workarounds?
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

8 REPLIES 8

Lingwisyer
Virtuoso
I cannot find the thread, but I remember one persons workaround to complex story structures (staggered stories, half stories, mezzanines, etc) was to save multiple Views with different Floor Plan Cut Plane heights then stitch them back together on a Layout.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

PVBergkrantz
Enthusiast
Thank you, I'll try something like that and see how it works.
| AC 25 Int | Win10 | i7-7800X | 32 GB | GeForce RTX 2060 6GB |

Lingwisyer
Virtuoso
If it is only the stairs that are displaying incorrectly, you could change the break position of the stairs themselves.

Stair Settings => Floor Plan Display => Break Mark => Break Mark Position



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

DavorP
Participant
Same problem here - can't find a solution.

Changes in floor plan cut plane settings don't seem to have any effect on stairs within a module.
Graphisoft ArchiCAD certified BIM manager

Daniel Kovacs
Graphisoft
Graphisoft
Hi,

Here's a link to the article about split-level that Ling mentioned:
https://helpcenter.graphisoft.com/?p=62812

This works fine in general cases. If you want to specifically solve the issue of the break mark, I would also suggest you to set the break mark to a fixed place (disregarding the cut plane).

Otherwise I just tried it real quick, and if I change the cut plane in the host file to go through my stair, it changes the floor plan view. Maybe your floor plan is not the home story? (because then the "above home story" settings might apply, that defines no cut planes at all).

Regards,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

ponaelius
Newcomer
Yeah, we've been struggling with this for some of our big projects.

Seems the break mark is only part of the issue as the layout options change from host file to main file.

Eg. in the host file the stairs are set to "relevant top story - above break mark visible" and when it is placed it completely changes to "relevant - middle story - multistory 2D: hidden - visible - hidden" and we get 2x break marks!

With more complicated projects I think it's less hassle with this tool to just model the stairs live.
AC16-AC23
HP Z4 G4
Intel Xeon W-2135 CPU @ 3.70GHz
Windows 10 Pro

DavorP
Participant
Yeah, we ended up removing stairs from hotlinks and just having them live. Lucky for us project was not huge but problems like this take away from the benefit of having hotlinks in the first place.

I just wish ArchiCAD had a region cut plane option like Revit does.
Graphisoft ArchiCAD certified BIM manager

Lingwisyer
Virtuoso
ponaelius wrote:
Seems the break mark is only part of the issue as the layout options change from host file to main file.

The settings vary depending on where the stair sits within the story structure of the current file. To get around this, within your hotlink, you can move or modify the stair to a height where you get the extra options, set those, then revert the height. In that way, within the host, the settings should match what you changed during your temporary modification.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!