cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Archicad 26 - 2D elements and lines not displaying correctly on 4K screen

Mykee
Contributor

Archicad 26 seems to display 2D element differently than 25 as I notice more distortions and thickening to hair lines (no line weight drafting). I usually use these in 25 to identify sloppy drafting. However when zooming in fully to these areas the elements are correctly drafted! I also notice straight lines 'stepping' across 1 - 2 pixels on elements like stairs (image attached) but also disappear when zoomed in. These distortions are a total waste of my time as I spend more time zooming in finding phantom drafting errors than I do drafting!   

 

Archicad 26 Int Build 5002 FULL, PC 4K dual screens


Screenshot Stair.jpg
5 REPLIES 5
Marc H
Advisor

Could it be that your AC26 install is using the default GPU instead of your dedicated GPU?  Also, is your True Line Weight button on?

“The best thing about the future is that it comes one day at a time.” - Abraham Lincoln

AC27 USA on 16” 2019 MBP (2.4GHz i9 8-Core, 32GB DDR4, AMD Radeon Pro 5500M 8G GDDR5, 500GB SSD, T3s, Trackpad use) running Sonoma OS + extended w/ (2) 32" ASUS ProArt PAU32C (4K) Monitors

Thanks Mark,

 

I stumbled on this thread with the solution. Apparently the new 2D rendering API has issues with windows based display scaling (mine is at 150%). so I reverted to the legacy rendering.api. fixed it for me. I'll just wait till the hot fix this.................

 

https://community.graphisoft.com/t5/Installation-update/Archicad-26-and-DPI-issue-on-4K-monitors-und...

 

The issue is that at 150% scaling, your 1 pixel becomes 1.5 pixels, which is not possible to display... To not have this sort of issue you would need to go up to 200%. @Mykee, when you say "this thread" it would be helpful if you linked said thread.

Lingwisyer_0-1685410512007.png

 

 

Ling.

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660

Thanks ling!,

 

The 150% comment makes sense, I'll try 200% but i fear it might make everything too big.  

 

Marc's reply updated to include link to other thread

If need be, it is possible to have an application ignore Display Scaling. This can be set within the program's compatibility settings. In doing this you can keep your desired scaling while disabling it for specific programs in which it causes issues in.

 

 

Ling.

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660