Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.
SOLVED!

Archicad 26 and DPI issue on 4K monitors under Windows 11

Paul King
Mentor

Has anyone solved the issue of ArchicCAD 26 displaying with 'fatter' lower resolution linework than earlier versions on same workstation (i.e. same hardware, same Windows version, same graphics driver etc) ?

This is with Archicad 26 version 4019 and using same 'Advanced Redraw Options' settings in Archicad 26 as with Archicad 24.

 

The consequence is that adjacent linework in detailed areas visually merges together into a blob far sooner than it normally does when zooming out, and small differences in line weight are hard or impossible to distinguish.

 

 

PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop
1 ACCEPTED SOLUTION

Accepted Solutions
Solution

OK, I have a workaround from Central innovation (my local reseller):

  
If I'm guessing correctly from your description, then your monitor is set to the recommended display scale too, which differs from 100% (125% presumably). If I'm correct then it is a known issue, you might want to refer to as DEF-11369. Unfortunately, there's no scheduled fix for it yet, but hopefully, it will be handled as soon as possible. The latest feedback from development is that the error seems to be that fills don't take into account the scale factor of the display.
 
There are two possible workarounds:
- use a 100% scale (it should be fine)
- or revert to the legacy rendering in the Registry Editor
 
This latter option can be achieved by opening up the Registry Editor app. Then follow this directory path to reach the rendering setting:
 
HKey_CURRENT_USER\SOFTWARE\Graphisoft\Archicad\Archicad XXX\Graphix\RenderingAPI. ('XXX' refers to the currently used AC version and language.)
 
Double-click the RenderingAPI registry line and type '-1' as Value data. This should revert back the rendering engine to the previous (25) version. Please be aware that if you change this setting, then you will have to change it back manually to '0' when an update or fix would be implemented regarding this issue.
 
 



 

PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop

View solution in original post

11 REPLIES 11
Laszlo Nagy
Community Admin
Community Admin

Hi Paul,

 

Can you attach a few screenshots so it is easier to see the exact problem?

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Paul King
Mentor

A side by side screenshot is attached showing same project open under Archicad 24 vs Archicad 26.    You may need a large 4K monitor to really appreciate the difference - which is possibly why the issue was allowed to remain unaddressed for so long since it was first reported in Beta testing (how large are the monitors used by Graphisoft developers?)  - but of course those of us working in front of large 4K monitors are forced to 'appreciate' the difference all day long.


2022-11-28_10-33-56.png
PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop
Solution

OK, I have a workaround from Central innovation (my local reseller):

  
If I'm guessing correctly from your description, then your monitor is set to the recommended display scale too, which differs from 100% (125% presumably). If I'm correct then it is a known issue, you might want to refer to as DEF-11369. Unfortunately, there's no scheduled fix for it yet, but hopefully, it will be handled as soon as possible. The latest feedback from development is that the error seems to be that fills don't take into account the scale factor of the display.
 
There are two possible workarounds:
- use a 100% scale (it should be fine)
- or revert to the legacy rendering in the Registry Editor
 
This latter option can be achieved by opening up the Registry Editor app. Then follow this directory path to reach the rendering setting:
 
HKey_CURRENT_USER\SOFTWARE\Graphisoft\Archicad\Archicad XXX\Graphix\RenderingAPI. ('XXX' refers to the currently used AC version and language.)
 
Double-click the RenderingAPI registry line and type '-1' as Value data. This should revert back the rendering engine to the previous (25) version. Please be aware that if you change this setting, then you will have to change it back manually to '0' when an update or fix would be implemented regarding this issue.
 
 



 

PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop

So this is a AC26 issue rather than WIN11, or does this not happen in AC26 with WIN10?

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5

I believe it is a general Windows issue.

Windows version (26) now uses a new method of displaying on the screen.

I am not sure it is the same issue affecting the positioning of text but I think it is.

Actually no, now I read the text issue is a separate issue - it has a separate registry fix.

But remember registry fixes only change what you see on your machine - not when the file is opened on another machine.

 

I have been told by Graphisoft that it is now recommended that 2D antialiasing be turned on in the Work Environment, which makes things look a little nicer.

 

 

Here are a few posts that discuss it all (in particular the text issue) further that I could find.

 

https://community.graphisoft.com/t5/Design-forum/Archicad-26-Update-4004-Preview-Antialising-BUG/m-p...

 

https://community.graphisoft.com/t5/Document-Visualize-forum/Fonts-displaying-incorrectly-after-movi...

 

https://community.graphisoft.com/t5/Wishes-forum/Archicad-26-review/m-p/355651/highlight/true#M21095

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

One way or another it is an AC26 issue related to a new 2D rendering method that has a new dependency on a windows subsystem

 

I can confirm that AC25 is fine under both Windows 10 and 11, and that enabling legacy rendering mode under AC26 (per the registry setting above) continues to allow AC26 work fine under Windows 11.

 

Very likely AC26 would have the same issue under windows 10 as under windows 11, since default scaling on large monitors is not 100% for either OS version (as I understand it)

PAUL KING | https://www.prime.net.nz
ArchiCAD 8-27 | Twinmotion 2023
Windoze 11 PC | Intel Core i9 10900K | Nvidia Gforce RTX 3080 | 32 Gb DDR3 | 2x4K monitor extended desktop

Thanks for your explanation. We've been putting off upgrading to WIN11 and I think we'll still wait a bit, but it is good to know this particular problem is not a WIN11 problem so much as it is a AC26 problem.

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5
Laszlo Nagy
Community Admin
Community Admin

As far as I know, in AC26, graphics on Windows is now using DirectX technology. Prior to that, it was using OpenGL technology.

On Mac, in AC25 and later, graphics is using Metal technology. Prior to that, it was using OpenGL technology as well.

I think the whole thing had to change because Apple discontinued support for OpenGL, so Graphisoft was forced to change the used technology, and now Archicad is using Metal on Mac, DirectX on Windows, both of which are Apple's and Microsoft's own technologies, respectively.

Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
arkitekt
Participant

got my hands on ac26 last week (our distributer waited for the "full" apple m1 integration) and now i have troubles in 2d with the display. with the same settings (and the same project) as in ac25 the new release stutters when i pan, text is shown too fat, hatches have inconsistent lineweights - just horrible, cant work this way. the distributer gave me some tipps, but they dont help or make things even worse.

I am really disapointed from gs - half a year after the first relase of 26 no working display driver ... i guess all energy goes into m1 relateted stuff ... wtf. and this is a small residential house - how about a larger projects? has anyone experienced the same? i keep working with ac25 - i probably will miss the hole ac26 - just paying ... WTF! 

have an older workstation, but far away from a weak one: i7 6950x, 32 GB, NVIDIA gtx 1070, 2 eizo montiors wqhd/hd > scale 100%!.

i would really expect that gs would test some configurations and give some advice, which cards have restrictions - i dont expect the impossible,  but some honesty!