cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

How to change the pen number to 0 in GOC and delete number 19 when exporting dwg?

LeeJaeYoung
Virtuoso

Walls seem to be the most basic cause of problems.
In the structural wall, the lower wall should be visible as a hidden line.

So I have to choose All Revelant Stories for the walls.
(If there is another way, please let me know)

The only way I could solve this problem was with GOC.
So I was able to select the lower wall line by specifying WALL, Home Story. And I had to designate the pen as number 19.

Question 1. I would like to know why I cannot select 0,-1.
And by selecting number 0, we want the lines to disappear.
(If it cannot be deleted by specifying number 0, etc., it will be added to the wishlist.)

Question 2. When exporting dwg, is there a way to not export this line 19 to dwg?
(Is the only way to write a program such as Autolisp to delete layers with the number 19 in the layer name?)

 

AC27 on window 11
2 REPLIES 2
Barry Kelly
Moderator

Only fill background pens can be 0 (transparent) or -1 (same colour as the screen background).

Pens for lines and polygon edges can not be 0 or -1.

 

I have no idea what you are trying to do with your DWG export, but you can set up a pen conversion table in the DWG translators.

I have never done it as I have no need to, but I believe the best way is to have a sample DWG to use as a template which you can choose in the 'Save Options' of the translator setup.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

When I set it to number 19, it did not disappear but appeared in the CAD file.
So the way I can do it is to turn it off in Autocad.

And the problem is that even when exporting to dwg, the overlapping lines are exported without any processing.
I think I can handle it, but I don't think I can.
This is a question often asked by BIM haters.
There are so many lines in REVIT.
If this happens, I think there will be a lot of lines that ArchiCAD will need to support as well.
I don't know if it's a PDF, but in Korea, the RVT and PLN files that were delivered as DWG should be delivered quickly.

AC27 on window 11