About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Problems with updating the layout book. BGArchiCAD

Not applicable
I having problems with updating the layout book. First, BGArchiCAD is taking forever to open the .pln file. I will get two or three 'ArchiCAD is not responding' messages before it ever opens. When it finally opens, I get an error that says 'Error while reading file: (file name).pmk (256: File is not found, connection failed.) This message occurs if I'm updating an existing file of importing a new one. This only occurs with linking to .pln files.

I on a Mac 10.3 and using AC81. When I first installed the update it worked fine for a couple of days. Then started getting the message above. I reinstalled and it worked only once and then it started back since.

I'm having this same problem with other machines in the office. Oh, this is occuring regardless of being local files or over the network.


is there any perceptable difference between your problems when updating a local file as opposed to a networked one?

moving your file locally from a server will not necessarily change the file path to the libraries if they are on a server, and therefore not really help with BGarchicad's file loading time if you have big/lots of libraries stored on a server.

also - archicad/BGarchicad/plotmaker all have problems if, on a mac network, there has been some interruption to the file path, i.e. network going down, disconnecting then reconnecting to servers. . . when i have had the 'error reading file: <>.pmk' message in the past, it has usually been something to do with this.

you could try quitting archicad/BGarchicad/plotmaker, then, ensuring that you are connected to the necessary servers, try again.

if that fails, go to "Drawing Usage", select all of your drawings and relink them back to the orginial file, (or your local copy if that's what you are doing to help speed things up).


ps - where is "Work"? sounds like a place i know well!
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Not applicable
These are reoccuring problems even with the lbk, pln, and library being local. I'm getting this message on "new" pln's importing to "new" lbk's. Do you have any other suggestions? The only thing I can think of the to try 8.0v3 Plotmaker, but I love some of the new functionality of 8.1. I wonder if 8.0v3 will read the 8.1 library and lbk.

Not applicable
Just a guess, but you might want to repair permissions on your AC installation drive AND the PLN drive (if they're different).

The "connection failed" error makes it sound like your PMK file can't be accessed properly. Otherwise I suggest sending the error code to GS support. Make THEM decipher their own stupid unhelpfull error messages! 😉

Not applicable
We've had the same problem, with large AC files, i.e. a big site plan say 1 x 1 km with a few hot-linked modules, it takes ages to even edit the AC file let alone update it when its in PM, I'm tired of watching spinning beach-balls!.

However when accessing the same file off a PC running Windows XP its is amazingly fast and responsive, updates in PM are more or less instant.
Same Network; File; library; Mac OS X Server; copy of AC and PM,... just a different client workstation, i.e. a PC and not the newer 1 Ghz G4 Mac running OS X.3??

Ben Odonnell
One thing to keep in mind guys. IF you are on a network using network licences ie if your using a 5 net key plug BGArchiCAD takes a new licence when importing a PLN so if you have 5 other people on the network using ArchiCAD BGArchiCAD can't start up as there are no spear licences..

Cheers Ben
Ben O'Donnell
Architect and CTO at BIMobject®
Get your BIM objects from

Not applicable
We had a similar probrlen and what we did was trash the Graphisoft preference folder in the users/clientname/library/preferences/Graphisoft.. Archicad regenerates the the prefs to the default settings and then it worked fine. Some of the customized settings will be lost but I have found that if things get buggy with Archicad a preference enema does the trick.


Mac OS X 10.3.2 and AC 8.1

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!