cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

General discussions
Posts about job ads, news about competitions, events, learning resources, research, etc.
SOLVED!

Edit Colour Palette Resolution Issues

Jarrod Phillips
Enthusiast

Hi All,

 

We are experiencing issues where the resolution of my colleagues Edit Colour palette does not match the actual size of the palette. The palette appears very zoomed in and there is no way to extend the palette to match the resolution. He currently cannot create or edit pen colours because of this issue. Does anybody know if this can be fixed by deleting or re-settings something in the Registry Editor? I couldn't see anything that was obvious to me when poking around in the Attribute Manager and Attribute Manager Palette folders in the registry editor. Any assistance would be greatly appreciated!

 

JarrodPhillips_0-1684135982940.png

 

Cheers,

 

Jarrod

BIM Manager | Graduate of Architecture
Fulton Trotter Architects - Sydney, Australia
Archicad 15 - 27
1 ACCEPTED SOLUTION
Solution
Barry Kelly
Moderator

Is your colleague running Windows OS with a high resolution monitor?

If so, has he set the Windows scaling factor to be something other than 100%?

This can cause problems.

 

Odd figures like 150% and 175% can definitely cause problems.

Maybe 200% is better, but even that may cause problems.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

View solution in original post

9 REPLIES 9
Lingwisyer
Guru

Match the resolution of what? Scale wise, everything in your screenshot looks normal. Is the cursor not lining up with the actual interaction location? Maybe an issue with display scaling, which is known to have caused issues in the past?

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660
Solution
Barry Kelly
Moderator

Is your colleague running Windows OS with a high resolution monitor?

If so, has he set the Windows scaling factor to be something other than 100%?

This can cause problems.

 

Odd figures like 150% and 175% can definitely cause problems.

Maybe 200% is better, but even that may cause problems.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry,

 

We tried changing the scaling factor to 100% (it was on 150%). This didn't seem to do a lot, appreciate the help though!

 

Also I now have an image of the issue:

 

JarrodPhillips_0-1684192206530.png

 

 

Regards,

 

Jarrod

BIM Manager | Graduate of Architecture
Fulton Trotter Architects - Sydney, Australia
Archicad 15 - 27

Although it is used by Archicad, that is a standard Windows operating system colour picker dialogue.

If it has nothing to do with the scaling factor, then I am not sure why it is enlarged in Archicad.

If you open something basic like Windows Paint and edit a colour, you will see the same dialogue.

Is that scaled as well?

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry,

 

This did ultimately solve the problem, Archicad just needed a restart after re-setting the scale factor. Thanks again for your help!

 

Regards,

 

Jarrod

BIM Manager | Graduate of Architecture
Fulton Trotter Architects - Sydney, Australia
Archicad 15 - 27
Miha_M
Advisor

Just to be clear with what you want to do here - if I understand this correctly you want the palette on the left side match the one on the right side? The one on the left side is just a standard Windows Color Palette (named Edit Color: PenNr. or Edit Selected Colors if more are selected) with some pre-set basic colors (top-left side) and available spots for custom colors (bottom-left side), everything else is the color picker, it's result and the RGB color codes next to it.

This whole window is just for color assignment of each color square you have on the right Archicad Pens & Colors Interface.

To edit one pen color in Archicad you have to double-click on one of those colored squares (a pen number) and then this second window (windows color palette) opens up. Here you can modify the pen's color. For a custom pen color scheme you'd need to go through all the pens and assign each a custom color. You can also select more than one pen at once (using the shift or ctrl key) to adjust all picked colors or their Pen Weight.

 

Miha_M_0-1684146828341.png

 

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

Jarrod Phillips
Enthusiast

Hi All,

 

To be clear, the imagine shown above is indicating the palette which is effected. It does not show the issue as I cannot reproduce the issue on my own machine. The issue is that the pen squares appear about 3 times the size and cannot fit into the standard resolution of the palette. I am after a way to reset the resolution of the palette. My assumption is that this might be achievable using the registry editor, however I may be wrong about this. I am open to other suggestions.

 

Regards,

 

Jarrod

BIM Manager | Graduate of Architecture
Fulton Trotter Architects - Sydney, Australia
Archicad 15 - 27
Miha_M
Advisor

Ok, then this is most likely a scaling problem as @Barry Kelly said. If and how this window resolution can be adjusted is beyond my abilities. But I've found some info about this Interface here: Color Dialog Box - Win32 apps | Microsoft Learn, maybe somebody else can find out how this can be adjusted so it fits the screen resolution.

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

Miha_M
Advisor

I tried to recreate your problem with setting my scaling factor to something else then 100%. With any possible combination I get the windows color picker at a correct resolution (Windows 11). There have been some similar issues reported on Adobe apps here: Solved: Re: Color Picker in Premiere Pro selects the wrong... - Adobe Support Community - 11722098

Based on what I've read there I would suggest that you update the graphic drivers, set your scale to 100%, restart your computer. If you have a NVIDIA GPU then set driver setting for "3D Settings/Adjust image settings with preview" to "Let the 3D application decide" or something similar (I don't use that GPU on current computer). If you are using a dual screen setup after the restart move Archicad to main monitor and try again.

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11