BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Arcicad 17 and Windows 7 not working

Not applicable
Hi all,
Installed AC17 on Windows 7, with recent hot fix, program will close just after splash screen with an error message "archicad 17.0.0 component has stopped working" I then try in demo mode and same thing. Then I tried to boot in safe mode and start AC17 and it opened, but it took about two minutes. I then close program, boot in normal mode and start program and all works fine. When I close the program and try and reopen it I get the same error message. So the only time I can get it to run is boot in safe mode, open program, close program, boot in regular mode then open program. I have also updated to the latest QuickTime. And FYI it does the same thing on two Windows 7 machines.

A couple of questions come to mind:

1. Did you install on both machines using the same downloaded file?
2. Do both machines run the same firewall/antivirus?

Edit: One more thing... Did this problem exist before the hotfix?
= v i s t a s p =
bT Square Peg
| AC 9-27 INT | Win11 | Ryzen 5700 | 32 GB | RTX 3050 |
Laszlo Nagy
Community Admin
Community Admin
It also could be that some program is blocking access of ArchiCAD to some folders it needs to access and write to. It happened to me before and ArchiCAD could only get to the start screen, then quit. After the blocking was handled, it worked fine.
Loving Archicad since 1995 - Find Archicad Tips at
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Not applicable
I ended up unblocking and still the same problem, updated windows 7 and downloaded the latest QuickTime (which I thought I had) and now all is good on both computers.

Thanks guys,
Learn and get certified!