Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Cannot install AC 25 under Windows 11 (ARM) on M1 Max MAC



THX for support!

MacBook Pro M1max with parallels and installing AC on windows11


just for the record... I have found VCRedist for ARM on Microsoft site:

installed it and tried to run AC25 installer - it doesn't work. the installer throws in the same error. 😞

BTW I wanted to run Windows + AC25 in Parallels on my M1Pro Mac for testing purposes.


Hi Rob


I'm tring to do the same but I can't find a solution.

Do you have any suggestions?



MacBook M1 Max 64GB- OS X 12.2.1 - Archicad 25


I thought I would weigh in on this issue as I had been trying to help a friend get their Windows version of Archicad 25 working on their new Mac M1 iMac running Parallels. There is no reason why Archicad shouldn't run on an M1 Mac with virtualization. Microsoft has done an extremely good job of getting Rosetta (the x64 to ARM translator) working beautifully in Windows 11 ARM.


The issue here is with the Archicad 25 installer.


Looking into the logs it is clear what is happening.


A Graphisoft verification program named VSCRTCheck.2019.X64/VSCRTCheck.exe is run to check if the required Visual C++ redistributable files are present. If they aren't it will install the ARM version of the 2019 redistributable alone.

VSCRTCheck is then called again to verify that the file(s) were installed correctly and it fails. There is unfortunately no log output stating why it fails. I am going to assume that the team at Graphisoft have hard coded a specific file name or version that is not detected because of the ARM difference. The reason I say this is because if I manually install the Visual C++ redistributable pack from 2015 to 2022 for x86, x64 and ARM the install still fails in this exact spot, unable to verify that the Visual C++ redistributable installed correctly.


The error here is with the Graphisoft team's Visual C++ redistributable checker logic. If we were able to bypass this I am very confident that the rest of the install would proceed effortlessly and the software would run as expected.


This is a BUG and should be treated as such.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!