BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Problem with Archicad 12 & 13 when installing OS X 10.6.2

Achille Pavlidis
Enthusiast
I have installed OS X 10.6.2 in my Intel mac, and i'm facing this problem:

When using the INT version of Archicad 12 or 13 with the US or British keyboard, for some reason the "alt" key does not function properly, i.e., when pressing cmd+option+D, nothing happens.
When looking on the keyboard shortcuts of the work environment when pressing cmd+alt+D a symbol appears (see attached image). This happens only with certain keys combination, for example cmd+option+C works properly (see attached image).

Any clues, suggestions??
Mac OSX 13.6.6 | AC 27 INT 5003 FULL
7 REPLIES 7
Ralph Wessel
Mentor
Achille wrote:
when pressing cmd+option+D, nothing happens.
Any clues, suggestions??
It might be conflicting with a keyboard shortcut for something else. For example, cmd-alt-d is often the default shortcut for hiding the Dock. Take a look at the Keyboard section in the System Preferences, under the Keyboard Shortcuts tab (see attached image). You can turn these shortcuts off or assign different keystrokes if conflicts arise.
Ralph Wessel BArch
Achille Pavlidis
Enthusiast
Thanks, Ralph but no, this is not the case. The problem is not specific to cmd+option+D, but to other key combinations to. And I have un-assigned cmd+option+D as a system shortcut.
Mac OSX 13.6.6 | AC 27 INT 5003 FULL
Ralph Wessel
Mentor
Achille wrote:
Thanks, Ralph but no, this is not the case. The problem is not specific to cmd+option+D, but to other key combinations to. And I have un-assigned cmd+option+D as a system shortcut.
It might be worth double-checking the Input Sources selected in the Language & Text settings in System Preferences.

Also, try showing the Keyboard Viewer while you type these commands to ensure the key-strokes are registering correctly (image attached). If there is something wrong with your keyboard, this will probably reveal it.
Ralph Wessel BArch
Achille Pavlidis
Enthusiast
I have checked the input sources. The problem appears when using the English or US keyboards with Greek as first language in the "Language and Text" settings of the System Preferences.
This is the way I have always used Archicad since today. If I select English as first language, all the Greek text in Archicad isn't displayed properly. In order to use the INT Archicad version and be able to use Greek, i have to set Greek as first language. It worked until 10.5, but now with Snow Leopard there a problem.
Mac OSX 13.6.6 | AC 27 INT 5003 FULL
Ralph Wessel
Mentor
Achille wrote:
I have checked the input sources. The problem appears when using the English or US keyboards with Greek as first language in the "Language and Text" settings of the System Preferences.
This is the way I have always used Archicad since today. If I select English as first language, all the Greek text in Archicad isn't displayed properly. In order to use the INT Archicad version and be able to use Greek, i have to set Greek as first language. It worked until 10.5, but now with Snow Leopard there a problem.
Try the fix at the following link: http://discussions.apple.com/thread.jspa?messageID=10480589&#10480589
Ralph Wessel BArch
Achille Pavlidis
Enthusiast
Nope, still nothing... sigh...

Thanks very much though Ralph, I really appreciate your interest.
Mac OSX 13.6.6 | AC 27 INT 5003 FULL
Anonymous
Not applicable
I also just upgraded to 10.6.2 and also have the problem where the option key is not recognized. Even when trying to option click a wall to pick up attributes.

Shift Key will not constrain walls either. The keys do work for some key commands, but shift constrain and option+click are essential!

I have tried a NEW and RESET ALL as well

Any help solving the problem would be very helpful!
Learn and get certified!