Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

2d representation library fills

Anonymous
Not applicable
everytime we place a library part there is always a solid fill. is there a setting to set the default 2d representation of the library part to not have a solid fill?
17 REPLIES 17
Anonymous
Not applicable
Which part are you using? To place a new object with the settings you want you have to set the parameters in the part itself. Another way would be to place the object, set it's properties as desired and then save it as a favorite.

Doug
Anonymous
Not applicable
all library parts - mostly sinks, refrigerators, toilets, chairs, etc. - i don't have an issue of not knowing how to change the properties after placing them. i just hate to keep changing it. there are some we can save as favorites that we use all the time. but archicad has a default of solid fill when we first place the object. why? it's becoming time consuming to always remove the solid fill after placing them for the first time. time consuming! it's obvious that most drawings don't need to be printed with a solid fill, so why default them as such.
Anonymous
Not applicable
I've placed several parts from both the AC11 and AC9 libraries. None of the had default settings of "Solid Fill" Are your libraries up to date?

Doug
Anonymous
Not applicable
i'm sorry - it's 100% fill. either way, it's annoying. yes, all our libraries are up to date. we'd have to change the properties to turn the fill off before placing the library parts.
Anonymous
Not applicable
I'm reaching here because I'm not sure what's happening.....

Right update (US, Int....)
Reload library...
Shut down, restart Archicad...


Short of editing the parameters of the library parts these are the only things I can think to try. Seems like a weird default for library parts. Hopefully one of the gurus will come up with a solution. By the way, you should have a signature with your OS, AC version etc. This can often help diagnose a problem such as yours.

Doug
Karl Ottenstein
Moderator
mdalida wrote:
everytime we place a library part there is always a solid fill. is there a setting to set the default 2d representation of the library part to not have a solid fill?
You've got to at least tell us what version of AC you are on - please click 'Profile' near the top of this page and fill in your specs in your signature.

Library parts 'have' to have a fill for QuickSelection to work. The US library does not use 100% fill, but rather 'Background Fill' with the color set to 'screen color', so that the fill is essentially invisible, other than hiding anything below it.

It sounds like you have messed up your file attributes so that you have the wrong fill and perhaps the wrong pens. The library is intended to operate with the default attributes delivered with ArchiCAD ... any changes to those attributes (deletions or changes - not appended additions) require at least intermediate to advanced intermediate ArchiCAD knowledge.

What exactly is the problem you are seeing with your 100% fills? When printing? On screen?

Do you know how to use Attribute Manager to verify your key attributes (fills, lines, pens, etc)?

Karl
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Anonymous
Not applicable
The problem is that when we choose a library part the 2d repres in the preview window already shows the object with a 100% fill. So, when we place the object it not only shows as a 100% fill on the screen, but on print as well. We haven't changed any attribute settings.
rocorona
Booster
We miss an important information: what COLOUR is the fill?? You may have opened an old file, with a different pen setting and, since then, all new projects will use that attributes.

In Italian localized ArchiCAD, version up to 9 used pen 91 (white) for background. This means that using those old objects in new versions (with standard settings) or new objects with "old" settings will results in strange colorizations...
_________________

--Roberto Corona--
www.archiradar.com
AC18 - ITA full on Win10
_________________
_________________
Gerald D Lock
Advocate
I have a similar problem, as I'm using a pen table that has been around in our office since v.8 or 9 at least I think.
The standard AC12 objects now seem to have pen 19 as the default background is that right?
My pen 19 is a mid grey, assigned in a bunch of custom objects we have in the office for Auto text... hence there is a problem similar to that originally described by mdalida

My question (and I suspect mdalida's too) is:
Is there a a way (a script maybe?.. i'm grasping at straws here) to globally change the default background pen to be 91 (white) again?

I really hope so, as it will be tedious & costly (time-consuming) to change all objects manually.
ArchiCAD 24 (build 5004)

MacBook Pro (16-inch, 2021) Apple M1 Pro 32GB RAM | MacOS 12.0.1



Melbourne, Australia

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!