Got a minute? We appreciate your feedback:

Graphisoft Learn survey
Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

Auditorium seats

Not applicable
Hi all,

I have the following problem. In the Chairs library, the first object is the Auditorium seating which can be stepped up in height (angle or height increment). This doesn't work in AC12 -although it worked fine in 11- or am I doing something wrong?

Any help appreciated

Not applicable
No, the AC12 version does not work correctly. I have attached a corrected version which seems to work.

They made a mistake in the 3d script where they add the height. I simply copied over the correct line from the AC11 version.
		! --- Chairs ---------------------------------------------------------------

		for j= 1 to m
			bLastChair = (j=m)
			gosub "one chair"
			addy gs_seat_width
		next j
		del m+1

!!!		addx -di			!!!wrong!!!
		add -di,0,gs_dis	!!!corrected

	next i

! ===================================================================
! Subroutines
! ===================================================================
Hope it works for you!

Karl Ottenstein
Thanks, Peter. I just reported this with a link to this thread.

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.2, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Not applicable
Hold your horses, spotted another mistake!

The backrest arc radius doesn't work. The code calls the same macro as the base cushion which doesn't have that option.

I have added the call for the "fa_cushion_backrest" macro and required parameters. It seems to work now, but my GDLing skillz aren't the best so check it works correctly for you.

Perhaps I should be submitting an invoice for my time spent!

Not applicable

I'm using the localized Greek version of AC12. I tried changing the 3d Script of the part but the "Too many parameters in line 168" message keeps popping up. Any chance of a step-by-step procedure?

Thanks again

David Maudlin

Make sure the command is add, not addx as in the original code. The add command needs 3 parameters (x, y & z), the addx only takes one (x), so if you use addx with 3 parameters, you will get this error message.


David Maudlin / Architect
Digital Architecture
AC27 USA • iMac 27" 4.0GHz Quad-core i7 OSX11 | 24 gb ram • MacBook Pro M3 Pro | 36 gb ram OSX14

Not applicable
Davids right, check it looks exactly like the code posted above. You can see they forgot the all-important gs_dis which controls the height.

I've attached an image showing what the Mk2 modifications should look like. See if it's any use to you.

If your still having problems, it may be easier to upload the greek version, and I'll try to modify it for you if you like. I assume the code is still in english!

Place the Greek version on your floorplan, select and open it by doing a Ctrl+Shift+o, then file - save as. You will need to Zip it up to attach it to your post.

Edit - Corrected mistake on image.

Not applicable

will this fix the 3d script of the library part for good or will I need to save another instance of it?


You need first to extract the library from the "container" (.LCF file). There is a command for this, in Archive>Library and Objects submenu.

Edit and save your Object, then rebuild a new container file (use the same name of the previous one).

--Roberto Corona--
AC18 - ITA full on Win10

Not applicable
Roberto thank you, it worked out ok.

David sorry my mistake. I forgot to delete the x from addx. Now it is all ok.

Peter are you sure this is right? I tried the changes for the back rest and it really messes the seats up.But will check again.Probably my mistake.

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!