Choose your top Archicad wishes!

Read more
Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

AC27 3d window performance broken on Windows, developers refusing to help

MASz
Enthusiast

EDIT: The cause of the issue is that DrawShadowsDuringNavigationOGL is bugged. This affects performance even when shadows aren't turned on. It needs to be set to 0 in the Registry Editor under:
Computer\HKEY_CURRENT_USER\Software\GRAPHISOFT\Archicad\Archicad 27.0.0\GSModeler\DrawShadowsDuringNavigationOGL

 

I have been dealing with severe 3d performance problems in Archicad 27 (frame rate drops, stutter, unresponsiveness) that are not present in 26. 3d window is the default Detailed Shading, no shadows. These mostly affect medium sized projects. I have lodged a ticket through Central Innovation (reference number #142104) and have been discussing this issue for months. I am very reliant on using the 3d window for my modelling and it needs to perform properly for me to be able to work in Archicad.

 

So far the Graphisoft developers have failed to carry out a proper investigation or even attempt to understand what my issue is. They have come back with nonsensical responses that don't address anything I've raised.

 

The problem is so severe that I have been unable to use Archicad 27 and have had to stick with 26. I have attempted to investigate on my own, provide workarounds, provide videos demonstrating, perform cleans, run FastLogger and suggest avenues of investigation, PLA files. Yet, much of this has been ignored and misunderstood by the developers.

 

This is clearly an unacceptable state of affairs. I am still waiting for a proper response and to be actually able to use 27. This is on top of the 2d drawing infrastructure being completely broken with scaling. So, both the 2d and 3d are broken - I am trying to help and it hasn't gone anywhere so far.

 

I am not sure if this is just isolated to Windows and if other users are experiencing similar issues to me? I am also not sure what everyone else's experience is dealing with technical issues but I don't often hear much positive on that front.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
17 REPLIES 17
MASz
Enthusiast

I finally found a way to record the behaviour and performance of the workaround (while stutter is a bit harder to demonstrate). I have managed to record the Windows Game Bar on screen to show the FPS before and after. This workaround has similar behaviour on multiple PCs I have tested.

 

Clearly, there is a significance difference. It goes from 45 up to 133. I have been trying to get answers from Graphisoft about what is going on here but they have not provided any information.

 

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
MASz
Enthusiast

I am still just waiting, there's still not been much progress. At least they do seem more committed to investigating this since I have made this thread. I have received some dubious responses from Graphisoft. I have queried these and did not receive answers back. It is still under investigation but I do want to keep this thread updated. To reiterate, I am looking for a fix for the performance issues that boosts the FPS, clarity on what is happening here and a commitment to improve how bug support is handled. I will also note that after looking around, there do seem to be a number of other users complaining about performance issues in 27 so it is not just me.

 

"with regards to shadows, Archicad has a hidden FPS counter. If the FPS drops below a certain threshold, the program automatically disables shadows. (I just wanted to share this information for better clarity.)"

 

Followed up by

 

"The customer has a powerful computer, but Archicad does not utilize its full potential by default, resulting in suboptimal performance. When the customer activates shadows, the graphics driver switches to a higher performance mode, but it does not revert to the lower mode after deactivating shadows. By adjusting the NVIDIA tuning settings to lock the highest memory frequency and maximize performance, the customer can improve performance. Sometimes, if FPS isn't locked, the graphics driver might behave oddly.
In Archicad 26, the implementation was different, which explains the change in performance."

 

This just raises a lot of questions. Is this intentional behaviour or a bug? Why is it performing suboptimally? What's the plan to fix this? I really don't think this is how graphics drivers even work, so I asked for the NVIDIA settings they would recommend changing. No answers. As mentioned previously, I have played around quite a lot with NVIDIA settings and it did not affect performance.

 

"Firstly, it's important to note that Archicad 27 utilizes different 3D addons compared to AC26. Theoretically, this shouldn't lead to significant performance changes.
The developer mentioned that the customer is using OpenGL as the 3D style engine instead of the default Direct3D, which could potentially be a contributing factor."

 

I said that I am using the default 3d style, so I don't know what they are talking about. According to this article: "From Archicad 26, Direct3D replaced OpenGL as 3D graphics API." Ok, but if I have a look at the Add-On manager in Archicad 27, it says Hardware acceleration uses OpenGL Engine.gmx. So I asked for clarity on this point because it's not like you can easily pick between OpenGL and Direct3d as the point would suggest. No answer.

 

"Firstly, the RenderingAPI needs to be set to 0, otherwise, it reverts to legacy mode."

 

Don't know why they said this either. I have tested it with both RenderingAPIs, performance is the same. Archicad is unusable with the new drawing infrastructure with Windows display scaling, so of course this is set to -1. It's the workaround Graphisoft have suggested for it!

 

With regards to 26 and 27, my local reseller said:

 

"In general my understanding is that it’s pretty complicated to compare the performance of AC26 and AC27 in this manner of testing, as there are many factors that are present now and weren’t before, so changes are not only in the 3D window."

 

This could be fair. Still though, compared to 26 the default performance is way worse, then after workaround it's significantly better? So I don't know.

 

It just seems like Graphisoft are struggling with this issue and information is not even clear internally. I'm skeptical it will be any better in Archicad 28 if not fixed in a 27 update. But just keep in mind that high FPS is possible, it's just locked away at the moment. To me it's crazy, I think it's exciting that you can get such high FPS and I initially came into this issue excited at least that this could be the default. But I am not getting that from Graphisoft.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display

Daniel, your team has given up on the issue despite what you have claimed. You do not have a proper answer to my problem and the team closed my ticket. We are back to the developers refusing to address the issue.

 

Here are some of the claims:

"I had a long talk with my manager and the development and we consider this FPS fluctuation as normal behaviour caused by the more than 1.1million polygons and the shadows. As it is not visible with human eyes, only with FPS counter, we even think it is totally acceptable performance. So now on we think this customer should be handled by communication. Let me try to give you some more ammunition to do this. Please don't copy this message to the user."

 

Please don't copy this message to the user huh? Nice. What a thing to claim as well that I can't see the difference between 45fps and 133fps. That is not FPS fluctuation, it's performing at a third of what it should be on my PC. I recorded the frame rate because I knew that Graphisoft would try the gaslighting approach with me, as they have attempted in the past to avoid fixing bugs. The facts are there whether Graphisoft chooses to deny them.

 

As I have said to them multiple times, I am complaining about the performance without shadows. But they have repeatedly misrepresented my problem in the ticket as well. Again, standard GS support behaviour. What about the unresponsiveness? The performance issue is more than just the low FPS. That is just part of it and a way to objectively measure the performance.

 

"The FPS counter remained the same after I turned on/off the shadows,"

This may mean that they did not reproduce the workaround as I have demonstrated. I have explained it multiple times. It is not about turning shadows on and off. It is about turning shadows on, moving around until it gets overloaded, then it turns the shadows off while moving. It's right there in the video.

 

"It's likely that the driver or the operating system is affecting performance in the background, perhaps to conserve energy. This is a common occurrence with modern video cards."

They showed a screenshot for graphics performance preference in Windows. I have tried with forced high performance in Windows. No difference. Furthermore, the performance is tied to the 3d window itself as I have already stated as the problem. If I run the workaround, the performance is good. Then if I close the 3d window and re-open it, the performance is back to poor. That rules out this theory.

 

"it's clear that this FPS change is unrelated to Archicad."

I have proven that is Archicad by ruling everything else out. Does any other application behave like this? No. A program like Unreal Engine is easily hitting 100% GPU usage, whereas the GPU usage is limited in Archicad. Also Archicad 26 is running fine.

 

Just to further prove my point, I have managed to make a video from my Surface Pro, it was difficult to capture but here it is:

 

 

It is the same issue reproducible on a completely different hardware setup. And yes, set to high performance there. If that's not enough, here's a third video:

 


That is on an old R552JK laptop. It is Windows 10, completely fresh installation. There is not anything there that could possibly interfere with Archicad.

 

Apparently, this went through the hands of multiple senior tech people in GS as well. Conclusion from months of investigation: they turned the shadows on and off, said it looked fine and that I shouldn't complain about the performance being bugged because high refresh rates are fake news anyway.


So, got any more "ammunition" for me?

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display

Dear @MASz,

Let me apologize for the content of the internal communication that was shared with you. The intention of that message was to provide internal context and facilitate ongoing discussion within our team regarding your case. I regret that it was not appropriately handled and that it led to feelings of mistrust or frustration on your part.

We are going to handle the situation together with your local support provider and make sure this does not happen again. Thank you for bringing this to our attention, and we apologize once again for the inconvenience caused.

Regards,

Tamás Gáspár

Even so, it demonstrates that Graphisoft didn't want to test the issue further despite the testing being inadequate in the first place. The ongoing discussion was not set out to be constructive and would not have lead to any solution. I am glad I saw the internal communication as it is revealing.

 

Everything that Graphisoft wrote as possible solutions were wrong, all provably soon. I can prove all of it is wrong in screenshare, in video. Even suggestions like trying to overclock the GPU in MSI Afterburner do not make sense - because the usage is low in the first place. The evidence is overwhelmingly there that it is a problem within Archicad.

 

It is to the point where I would deem that AC27, along with the bugged 2d drawing infrastructure, is substantially faulty under the terms of the refund. One of the biggest ways I use Archicad is to model while using 3d explore. It is a part of my business model and one that clients love to engage with. The way I use Archicad necessitates the maximum performance possible. I am not complaining just to be difficult, AC27 is legitimately unsuitable for my purposes.

 

There is still no admission that Archicad has a problem and no way provided forward. It shouldn't even require discussion from me. Graphisoft should have recognised the issue from the start, looked deeply into the systems that drive the 3d window performance and worked towards a resolution. I have provided several avenues of investigation for that, as well as extensive system information. I have provided the testing now that demonstrates the problem on multiple hardware configurations. I have ruled out any external settings, or any settings within Archicad.

 

I shouldn't even need to raise it in the first place because performance should be properly tested internally to make sure the version is suitable for release. It seems like the Graphisoft support is just guessing what is going on and they are not capable of fixing it. There isn't much there to suggest otherwise currently. As I have pointed out in the ticket, it seems like very cursory observations. It is the kind you would expect from other users, not from developers who are supposed to understand the inner workings of Archicad and what might be going on behind the scenes with the performance.

 

_________

 

New observations:

 

The workaround actually works in AC26 as well. So the main problem is that the default performance in AC27 is significantly worse.

 

I tried using it today without the workaround and it gave me feel physically ill pretty quickly, no exaggeration.

 

To trigger the workaround more easily, I would recommend dropping in Tree Model Detailed and turning the settings way up along with turning the shadow on. This will tank the FPS which is what is needed.

 

Tree Model Detailed.png

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display


MASz,

looking at your screen recordings I don’t see an issue with the 3D performance, this is similar to what I get in both Archicad and Revit (although when file gets to 5-10M polygons Archicad outpaces Revit).

Remember you are using a BIM package which is essentially a database with a graphical representation/ interface and all you see in 3D window needs to be recalled from the database then generated for screen display, this is why the frame rate is constantly changing as it is pulling up the data to display as it comes into view. 
If your expectation is like that of a game you will not get that in any BIM package I am aware of.

Scott

Regards,

Scott
MSI Creator ZP16, i7-12700H, 32GB RAM, RTX 3070 8GB

Except that I do get that performance in Archicad after I perform the workaround, which is what the first video on my desktop is demonstrating. The videos are not meant to be demonstrating the extent of the performance issues, which are numerous and obvious. The videos also demonstrate that the workaround works on multiple computers and is not just isolate. The performance across the board is not where it should be and not what Archicad is capable of.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
MASz
Enthusiast

The issue is that DrawShadowsDuringNavigationOGL is bugged, as I have discovered. It needs to be set to 0 in the Registry Editor under GSModeler/DrawShadowsDuringNavigationOGL. This improves performance in the 3d window, even if shadows aren't even turned on. Therefore I would recommend leaving it off by default.

 

The workaround was probably just turning this parameter to 0 when FPS drops below a certain point in the 3d window to preserve performance. This is also behaviour that should be documented.

 

The bug is present in 26 as well, it is just much more of an issue in 27.

 

I have been waiting for acknowledgment of the bug from Graphisoft as well as further information, but so far there has been no response. 

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display