cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.
SOLVED!

Beam auto extending when its not supposed to

madarHR
Participant

Hi, im relatively new to archicad and i cannot find a solution for the following problem. Im trying to model prefabricated concrete secondary roof beam.

Its a 3 part segmented beam with all 3 lengths fixed. The beam shows up fine when it floats in free space but as soon as i place it on my main roof beam ARCHICAD auto extends it past the fixed length point. How can i stop this? It has to go from middle to middle of the main roof beam not till end to end.

 

 1.png2.jpg

 

Operating system used: Windows latest

1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Barry Kelly
Moderator

One way is to place them in separate layers and make sure that each layer has a different intersection group number (set this in layer settings).

Or you can have the beams in the same layer and set the intersection group number to zero (0), but that means the beams will not interact with any other elements either.

 

Another way is to ensure the beam reference lines do not touch in plan view.

Set the reference lines of those beams at each end to the outside.

Because you change the reference line anchor position to the side, you will also have to reposition the beam back to where it was.

 

BarryKelly_1-1718542698937.png

 

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

View solution in original post

2 REPLIES 2
Solution
Barry Kelly
Moderator

One way is to place them in separate layers and make sure that each layer has a different intersection group number (set this in layer settings).

Or you can have the beams in the same layer and set the intersection group number to zero (0), but that means the beams will not interact with any other elements either.

 

Another way is to ensure the beam reference lines do not touch in plan view.

Set the reference lines of those beams at each end to the outside.

Because you change the reference line anchor position to the side, you will also have to reposition the beam back to where it was.

 

BarryKelly_1-1718542698937.png

 

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Thank you, the first method of making a seperate layer for the most top beam and changing its intersection group worked perfectly. 

Setup info provided by author