Choose your top Archicad wishes!

Read more
About Archicad's design tools, element connections, modeling concepts, etc.

GPU Optimization

Jan Ellis

I'm a relatively new user of Archicad. I'm sure this topic has been well documented and I've read several posts and articles related, but I'm still not clear on the mechanics of how Archicad utilizes the dedicated GPU in my system. I appreciate that there are many factors and variables that affect performance such as the overuse of solid element operations, lots of trees=leaves=polygons, duplicates, etc. but if one takes these out of the equation, I am trying to determine what kind of GPU utilization I should expect to see when looking at the in built monitoring tools employed in Windows.


I've attached some images to try and illustrate. Whether I set the GPU (NVIDIA QuadroP620) to auto-select the required processor or whether I set it to use the dedicated GPU to when operating Archicad, I seem to get a result that is almost entirely reliant on the CPU and to a small degree, the integrated GPU, while the P620 is only showing about 1% utilization.  This is measured both when I'm, say, opening an elevation or a section with shadows turned on, or when I'm rendering a 3D image using CineRender. Am I missing something? Isn't the dedicated GPU supposed to be doing the heavy lifting?  My system set up isn't high end, I know (Intel 2.6GHz i7, 16G RAM) so I'm not expecting it to be a super smooth and easy ride when my drawings get more complex, but regardless, wouldn't one expect to see the GPU to be doing the bulk of the work? If so, any advice on how to get it set up to do that?


My only guess is that perhaps the Windows OS (11Pro) might override the engagement, for lack of a better term, of the GPU, as it seems to suggest in the NVIDIA control panel, though that Windows graphics settings page only seems to allow custom options for built in Windows apps like Camera and Films & TV, so I might be barking up the wrong there. I've tried updating the driver for the GPU and changing individual control panel settings (both Global and Application specific), but have not seen any change in the ratio of utilization between the CPU, the integrated GPU and the dedicated GPU during processor-heavy operations in Archicad, even though the NVIDIA activity monitor seems to suggest that Archicad and CineRender is running on the GPU.  Guidance would be highly appreciated.

gpu settings archicad.pnggpu test 4.pngwindows gfx settings nvidia.pngwindows display gfx.pngnvidia activity.png

I had to use msi's built in tool to override win11 as I was suffering from the same thing.

Not sure if your machine has any mfg software but it was pretty painful not utilizing my graphics card. Everything is dandy now.

Jan Ellis

Thanks for the response.  Would you be so kind to elaborate?  Where/how do I access the built in tool?  I have an MSI machine as well. 

in the msi dragon center, which if you dont have you should be able to download from their website, there is a setting there that lets you force the machine to always use the dedicated card.

Jan Ellis

I appreciate the effort.  Bummer, though. Looks like Dragon Centre only supports GeForce Cards, not Quadro models. Either that or it doesn't like Windows 11. Apparently there is a replacement version called MSI Center.  I'm trying to track it down on the MSI member center to see if that will support my system. I'll update. Seems strange that one has to go and find additional software that doesn't ship with the product to get components that ships in the product to work.

dragon centre system not supported.png

I'm pretty sure it's windows I didn't always have this issue. Not sure which build it started with but I am using the dev builds of windows 11.

My machine ships with dragon center, I usually delete it but it's the only thing that would take control over Windows.

What's odd is that it's only Archicad I have the issue with and only on the laptop screen. If I attach an external monitor it works as it should. if I'm using twinmotion no issues.

I've got a ticket ongoing with MSI to try and resolve this as well.  They initially me the stock advice of tick/select the right boxes in the NVIDIA control panel (which I had done already anyway).


I have the MSI WF65 Workstation model.  It turns out it ships with a similar bit of software to Dragon Center, called 'Creator Centre'.  MSI has not been clear on how to set things up in Creator Center, but I've made some attempts. It doesn't have a tick box to switch GPU like in your image of Dragon Centre, though I've added Archicad as an application and prioritized it in "Creator Mode" (whatever that means)  - image attached - but that doesn't seem to make any difference in performance or GPU engagement either.


Now they've instructed to install different drivers both for the integrated and dedicated GPU's.  I'll give that a go and report.


What I've also learnt from this Graphisoft page ( is that Cinerender seems to be almost totally reliant on the CPU (why on earth would it not be developed to engage the GPU?) so I guess it's no surprise to see almost no GPU activity when you use it to render.


As far as opening elevations and sections with a relatively high number of polygons and shadows turned on, for instance, it stands to reason that one could expect to see proportionally high GPU activity, though.  This is the main area where my system seems to lag significantly or the file crashes.


Thanks for your help. If you or anyone else knows more about the mechanics behind Archicad and GPU engagement/monitoring, I'm all ears.

creator center added archcad.png

I only render with twinmotion because of that.


I hope you get it figured out. i was going insane not getting the performance i knew i should.