Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

Upside down 3D grass in cinerender?!

Jackson
Contributor

Wow this one made me laugh when I realised what I was seeing... though I have no idea how to go about fixing this problem!

 

Just today I moved up to AC26 from 24 so I could render with all intel performance cores (apparently AC24 only uses the efficiency cores as a side note) and noticed that when I tried to render grass, it was rendering upside down! i even went and made a totally new file and put in a basic square mesh with grass as the surface override.

 

Please help haha i am genuinely at a loss at where to even begin troubleshooting this. i seem to be the only person on the internet who has had this issue, unless my google-fu is just not good enough. yes ive updated to the lastest update im on AC26 build 4019

 

grass.png

1 ACCEPTED SOLUTION
7 REPLIES 7
Barry Kelly
Moderator

Does it still happen if you give the mesh a thickness?

Or try it on a slab?

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

if i give the mesh a thickness then yes its still upside down (its just harder to see)

interestingly if i put the same grass surface on a slab it renders totally normally

 

Jackson_0-1674113983163.png

Jackson_1-1674114044512.png

 

Solution

I just tested it out of curiosity.

The top surface of the mesh does indeed seem to be upside down, with the grass growing downwards.

I even set the skirt height of the mesh as negative.

 

BarryKelly_0-1674115451957.png

 

But as soon as you start playing with the mesh heights it seems to fix up.

 

BarryKelly_1-1674115519657.png

 

Just a problem with perfectly flat meshes?

 

Although setting it back to a flat mesh a the reference plane seems to work now as well.

Maybe it just needs editing.

 

BarryKelly_2-1674115834211.png

 

Barry.

 

 

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

What a bizzare bug... I'm off work now, I'll try that in the morning and mark your reply as a solution if it works! Thanks for looking into this 

Jackson
Contributor

yep. can confirm this solution works! Hopefully this bug is ironed out in the next update 

Jackson_0-1674162688435.png

 

Jackson
Contributor

As an update to this, the results are more inconsistent than these posts suggest. i had a more detailed mesh with multiple slopes where this was also not rendering the grass correctly. So ultimately no idea what the solution is, mine was to go back to AC25 where the grass is greener and upright. Hopefully this is sorted out in an update eventually


@Jackson wrote:

Hopefully this is sorted out in an update eventually


Make sure you report this to your local Archicad distributor (support).

They can then pas the problem onto Graphisoft HQ for investigation/solving.

 

Mentioning it here is all well and good, but does not ensure Graphisoft are aware of it.

 

Barry.

 

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!