BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.
SOLVED!

Working Units accuracy with zero decimals

Vinicius Lima
Booster

Hello everyone!
I Use Archicad since AC12, and its incomprehensive for me since than:
If you set in "Project Preferences" > "Working Units", to zero decimals (doesn't matter if it is in meters or centimeters or other unit), if you create a wall with 1.24m lenght for example, EVEN if Working Units was setup to zero decimals, the software accept this decimals (creating a dimension you can check it).
Archicad shouldn't ignore your decimal typing, if you setup Working Units to zero decimals, and create a wall with just 1m?
PS: I'm not saying that the decimals shouldn't exist in this setup, becouse if you create chanfered walls it will happen anyway, but in the input (when you type) it shound't happen with the "Working Unit" set do zero decimals.

- Vinícius Lima - user since Archicad 12
from Brazil
Apple MacBook Pro 16" 2023 | M2 Pro | 16Gb RAM | macOS Ventura 13.5.2
1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Barry Kelly
Moderator

So let me try to understand this.

Your working units is set to meter with no decimals.

When you type (or stretch) a length of 1.24m, you want Archicad to only make the wall 1.0m long as per the working units?

 

That is not going to happen.

The Working Units is just what is displayed as you model (tracker) and in the dialogue boxes (heights/lengths).

Archicad still models with full accuracy - as you said if you trim angled walls there will be decimals.

 

If you want modules of 1m, then you set your snap grid to 1m and activate it so you can only work to the grid intervals.

 

Personally, I don't use grid snap.

If I want my wall to be 1m, I will type that in the tracker, so I get exactly 1.

 

If you are saying you do type 1 for the length and then you get a wall that is 1.24, then we need to look at the way you are doing this as it shouldn't happen.

If you are using the tracker for input, then you should get exactly what you type.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

View solution in original post

5 REPLIES 5
runxel
Legend

No, you got that wrong. It works just as intended. This setting is just for display.

I wouldn't want my input to be cutoff or rounded randomly. (It also makes no sense? If you want less, just type less??)

Looks more like you should look into "snap to grid".

Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»
Solution
Barry Kelly
Moderator

So let me try to understand this.

Your working units is set to meter with no decimals.

When you type (or stretch) a length of 1.24m, you want Archicad to only make the wall 1.0m long as per the working units?

 

That is not going to happen.

The Working Units is just what is displayed as you model (tracker) and in the dialogue boxes (heights/lengths).

Archicad still models with full accuracy - as you said if you trim angled walls there will be decimals.

 

If you want modules of 1m, then you set your snap grid to 1m and activate it so you can only work to the grid intervals.

 

Personally, I don't use grid snap.

If I want my wall to be 1m, I will type that in the tracker, so I get exactly 1.

 

If you are saying you do type 1 for the length and then you get a wall that is 1.24, then we need to look at the way you are doing this as it shouldn't happen.

If you are using the tracker for input, then you should get exactly what you type.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hello guys. Thank you for your answers.
I just don't see any reason for you to use the measure tape (for example) and it gives you a wrong information, blinding you to a systemic error. I worked as a BIM Manager in an architecture office with more then 30 users, and people just type thinks wrongly (even with the tracker), and once you type one time wrongly, the domino effects goes on. We have tried the "Snap Grid" but it doesn't work if you have curves, and chamfer walls/forms. I still think that the Working Units as it is, induces the user to an error because it is hiding from you the truth, the real measure. Perhabs, the "Measure Tape" at least, should aways show with all decimals, being aside of the Working Units settings?

- Vinícius Lima - user since Archicad 12
from Brazil
Apple MacBook Pro 16" 2023 | M2 Pro | 16Gb RAM | macOS Ventura 13.5.2

Okay, got that, but you're talking about different things.

The model quality control is not determined by how much you could see; there would need to be a cutoff at some arbitrary place anyway (Quick: Show us what 1/3 would look like as decimal, seeing all decimals of that!). So for QC what I did was having an expression evaluating the length of a wall and returning "good" or "no bueno". Then I have a schedule and I can quickly determine the walls that are odd.

Also everybody in my office needs to draw with the maximum available decimal places, and entering more than is visible is prohibited. It is about educationing the staff, too.

But letting the system doing something in the back not transparent to the user and basically overriding what they are drawing is clearly an anti-pattern.

Lucas Becker | AC 27 on Mac | Author of Runxel's Archicad Wiki | Editor at SelfGDL | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

To help solving that type of mistakes, for example, i have created a cotation set that clearly highlight acuracy problems and a GO that show static cotation problems. Every one in the office work with this.

 

Annotation 2023-03-06 140128.jpg

ArchiCad 3.43 to 26
MacOS Monterey
Learn and get certified!