cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.
SOLVED!

Zone do not calculate wall surface area

DianaCz
Contributor

Hello,

I am trying to calculate surface area of walls that surround each placed zone separately. Zones are placed to inner edges of the walls, all automatically updated. However, when I created schedule and used "Walls surface area", almost all of them show 0.00 sq.m. I am using Archicad 26. Calculating zone's edge surface area and reducing doors and windows don't work since I have some empty sides without walls (one large room is separated to several zones for example). But it detects doors and windows, so I don't really get why it can't calculate wall surface area.

Every insight on what could cause such a problem will be very much appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Erwin Edel
Rockstar

If the zone would not have been 'touching' the walls vertically, that might be the problem.

 

If you need a quantity take off for wall finishes, you could also try scheduling the 'exposed surface'. I'm not sure if it can filter per zone, though.

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5

View solution in original post

4 REPLIES 4
Erwin Edel
Rockstar

Is Construction Method set to Manual? It should be set to Inner Edge (I think you confirmed that, but just to be sure).

 

If you need to split the zones up, you can use lines or polylines as Zone Boundary as well and still use Inner Edge method.

 

Also check that the zone has correcr Bottom and Top settings for elevation.

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Hello Erwin,


Thank you for your reply. No, Construction Method was already set to Inner Edge. Yes, I am using polyline as a zone boundary (this part works just fine). Zones now are linked with 0 offset from one story (aligned to below placed slab's top surface) and with exact offset from next story (aligned to next slab's bottom surface). Could it be affected that surrounding walls' are places a bit lower? Their reference line is placed with -200 mm offset to story (tried to show it in the section, attaching the draft). Or what else could you mean by Bottom and Top settings for elevation?


Scheme nr. 1.png
Solution
Erwin Edel
Rockstar

If the zone would not have been 'touching' the walls vertically, that might be the problem.

 

If you need a quantity take off for wall finishes, you could also try scheduling the 'exposed surface'. I'm not sure if it can filter per zone, though.

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5

I didn't find "Exposed surface" in zone listing settings, however, "Walls surface area" started to work, so the problem is solved although I still don't know why and what happened, because I didn't change anything, just reopened the project. Maybe it was a temporary bug. Thank you for your time and advice, Erwin. I'll accept your response as a solution to close the topic.