Parametric design
About Rhino & Grasshopper and PARAM-O.

Grasshopper not found install issue.

Anonymous
Not applicable
Hi all. I've recently upgraded to AC22 and now having a problem with Grasshopper-archicad connection. I can't install it since it says 'Grasshopper is not found'.

Previously I used connection for AC21 on the same PC and it worked fine. I have removed the old connection plugin before trying to install the new one for AC22. I've also tried to reinstall grasshopper but the installer still doesn't see it. Everything is installed to the default location.

GA-AC connection 2.1 (22.0.3009)
AC 22 3009
Rhino 5 SR5
Grasshopper 0.9.0076
WIN 7 64bit
12 REPLIES 12
mikas
Expert
Grasshopper comes built in with Rhino just as you wrote, no additional download is required for GH. The AC/GH connection plug-in has to be downloaded and installed of course.

You can only have one connection plug-in installed at any time though. You have to choose a ArchiCAD version to use, and stay at it if you want the AC/GH connection to function. Make sure you uninstall other/older plugins first, only after that install the new one.

On Mac:
AC22->Rhino 5.x, AC/GH plug-in accordingly
AC23->Rhino 6, AC/GH plug-in accordingly

Please read this post too, it might help you:
https://archicad-talk.graphisoft.com/viewtopic.php?f=43&t=66248&p=299088&hilit=grasshopper#p294897
and maybe this one too:
https://helpcenter.graphisoft.com/knowledgebase/75721/
AC25, Rhino6/7+Grasshopper, TwinMotionMac Pro 6,1 E5-1650v2-3,5GHz/128GB/eGPU:6800XT/11.6.5 • HP Z4/Xeon W-2195/256GB/RX6800XT/W10ProWS
kkmac
Contributor
Hi. I need to install this remotely from command line to about 100 computers. but got this message:

mbpro:~ AddigySSH$ sudo "/Library/Addigy/ansible/packages/GrassHopper ARCHICAD 24 Connection (24.0.4018)/Grasshopper Connection Installer.app/Contents/MacOS/installbuilder.sh" --mode text
-
Error: Error.
Grasshopper is not found on this computer. To use Grasshopper-ARCHICAD Live
Connection for ARCHICAD 24, you must install Grasshopper.
Press [Enter] to continue:
mbpro:~ AddigySSH$


I didn't encounter the above error if i execute the above command locally on the computer itself:

bash-3.2# sudo "/Library/Addigy/ansible/packages/GrassHopper ARCHICAD 24 Connection (24.0.4018)/Grasshopper Connection Installer.app/Contents/MacOS/installbuilder.sh" --mode text
Password:
----------------------------------------------------------------------------
This program will install Grasshopper-ARCHICAD Live Connection for ARCHICAD 24
on your computer.

----------------------------------------------------------------------------

Please read the following license agreement.



Open in Browser... [Y/n]: n


----------------------------------------------------------------------------
Select an installation directory for Grasshopper-ARCHICAD Live Connection for
ARCHICAD 24:

[/Applications/GRAPHISOFT/ARCHICAD 24]:

Please help.
Since ARCHICAD 20
 macOS
mikas
Expert
Wow, quite a big task you have at hand there.
Did you install Rhino first?
If so, Grasshopper should be there too, it's built in to Rhino.

I can't help with remote install though, sorry.
AC25, Rhino6/7+Grasshopper, TwinMotionMac Pro 6,1 E5-1650v2-3,5GHz/128GB/eGPU:6800XT/11.6.5 • HP Z4/Xeon W-2195/256GB/RX6800XT/W10ProWS

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!