Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Project data & BIM
About BIM-based management of attributes, schedules, templates, favorites, hotlinks, projects in general, quality assurance, etc.

Layer combinations stuck on "Custom" - Bug?

Not applicable

Is this a confirmed bug? I have experienced this on a few machines at my office where a saved view shows up with a "Custom" layer combination. Even after I manually right click the View, set the layer combination in the View Settings to a saved layer combination, then double click into the view, it still shows as "Custom". This is happening across all Views.

Goes away after a restart of ARCHICAD.


Problem is still there in AC25.
Actually worse.
I set the desired Layer combo in the Quick Options Bar.
It flicks the name up for a split second, then turns to "Custom" 
I publish a set of layouts with  this cutsom layer combo setting.
half the drawings are OK, the other half has the title block layers turned off!!!!!!!!!!


GS pls fix this problem ASAP!

I am having the same issue. It appears to have happened after importing layer combinations with the attribute manager.

Robert Wilkanowski
Archicad 27
Mac OS '14 Sonoma
Hardware: M1 Max with 10-core CPU, 32-core GPU, 16-core Neural Engine, 64GB unified memory
1TB SSD storage

I doubt it has anything to do with importing layer combos. I never did that, yet the problem is there.

Same problem occurred for me after importing layer combinations from another file.


It seems the layers combinations got a bit confused and every possible change reverted to "Custom".


The fix for me ...

I created "New" combinations based on each existing one and appended "2" to the name. Then deleted the old ones and finally renamed the new combinations without the "2".  Need to then reassign the layer combinations to each view.




Same on AC-27.  After deleting a bunch of unwanted layers, after import of layer combinations.

Updating won't solve the issue.

1) Yes , in the layer combination are references to deleted layers. But hey, importing layer combinations is a a common workflow, and deleting unwanted layers also. So..

2) Yes this is an official bug.

3) Since how many years already ?

4) Workaround is time consuming. 🙁.

Andries MIXD
MacBook pro 16 inch. 2,4 GHz 8-Core Intel Core i9, 64 Gb, Archicad 26-27

This is how, I have solved it:

  1. Just, refreshed the layer combinations (after switching off and on one of the layers- anyone) one by one.
  2. Then saved and closed the file.
  3. Reopened it with 'Open and Repair selected file' option ticked.


Shrutiniwas Sharma

MacBook Pro M1 Max
macOS 14.5

can confirm Open & Repair worked.

AC25 | Win10 | 64Gb RAM | Intel i7 13700F | RTX 4070 Ti
>come join our unofficial Discord server