cancel
Showing results for 
Search instead for 
Did you mean: 

3rd party installers for GRAPHISOFT products

mtron
Graphisoft
Graphisoft

In this article, you can find a list of additional software needed for installing or running GRAPHISOFT products. When you run the installer, it will automatically install those third-party products which are not yet installed, or which are out of date. If you don't want to or can't install these automatically during unattended installation, make sure they are installed separately beforehand.

BIMx Desktop Viewer 2019 Microsoft Visual C++ 2017 Redistributable (x86) for 32-bit editions of Microsoft Windows
Microsoft Visual C++ 2017 Redistributable (x64) for 64-bit editions of Microsoft Windows
IFC Model Exchange with Archicad for Revit 2020 Microsoft Visual C++ 2017 Redistributable (x64)

Installers of the following software packages update their previous versions, so you need the latest only for the proper operation:

  • Microsoft .NET Framework 4
  • Intel C++ Redistributables for Windows on Intel 64
  • CodeMeter Driver
  • WibuKey Driver

Reference Guide and Offline Help

Archicad 23 and newer versions provide up-to-date Help resources online which can be viewed with any modern web browser. The Offline Help needs one of these supported browsers:

  • Google Chrome 65.0 or above
  • Mozilla Firefox 59.0 or above
  • Microsoft Edge 40.0 or above
  • Microsoft Internet Explorer 11

Apple Safari 11.0 and above can be used after disabling local file restrictions. For this, follow the steps detailed in the Reference Guide.

Further documentation

A viewer application is necessary to read the PDF documentation provided with GRAPHISOFT products.

  • On Mac, you can use Preview, the default PDF viewer of macOS.
  • On Windows, you need an application installed separately to open PDF files—we suggest using Adobe Reader available to download from here.

Java for former installers

With Archicad 22 and newer, you do not need the Java Runtime Environment for installing the software.

In some cases, during installing Archicad 21 and earlier versions, newer, older, or corrupted Java versions could block the installation and uninstallation process of GRAPHISOFT products. If you have any issues like this, please consult the corresponding Install and Startup Troubleshooting Guide for a solution. You can find the Java installers that were bundled with the Archicad versions on this site.

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!