BIM Coordinator Program (INT) April 22, 2024
Find the next step in your career as a Graphisoft Certified BIM Coordinator!
Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

AI Visualizer Technical questions

Illes Papp
Graphisoft
Graphisoft

We know that taking part in an experiment can be challenging from time to time. Do you have issues with installing or running the Archicad AI Visualizer Add-on? This is your place to ask your questions and initiate discussion with others about technical difficulties you may experience while trying to install or run the experimental add-on, or generate images.

Illés Papp
GRAPHISOFT Senior Product Manager
128 REPLIES 128
CSvercl
Participant

Hello, i am having trouble just installing it.  i have tried copy/paste the text from the Archicad download PDF, as well as from the Home Brew website (per a tip on YouTUBE @DavidTomic channel).

please see screenshot.  i open Terminal, copy/paste the text into the Terminal, and click "Return".  immediately gives the error "Illegal variable name." 

it did download the Command Line Developer Tools (i think, it downloaded something).

thank you

ArchiCAD 27 on MacBook Pro with Apple M2 Pro chip.  United States.

Screenshot ArchiCAD AI Visualizer Install 2024-01-22 at 3.35.30 PM copy.png

Hi CSverci,

 

Thanks for the picture.

 

Please try to launch the bash shell first in the Terminal:
/bin/bash

Hit enter, then run the install command:
bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Andreas81ch
Booster

Hi there,

 

For this tool archicad 27 ai visualizer > what are the min. hardware requirements ?

ArchiCAD v6.5 - 27 / macOS / Windows
Switzerland (Schweiz)

Hi @Andreas81ch, please find the System Requirements button in the side menu of the Archicad AI Visualizer Community Group Hub page (Archicad AI Visualizer - Graphisoft Community) to read the most current requirements of the AI Visualizer Add-on.

Illés Papp
GRAPHISOFT Senior Product Manager
sknsnw9
Booster

At first it didn't work and got the results below.  So I tried doing all the steps again and it was the same results.  I extracted with winwar from download folder to C:/ folder.

 

NVIDIA RTX 3060 12gb vram

windows 10

 

Capture.JPG

 

I ran run.bat and runhighvram.bat and this is what i got: 

 

Capture2.JPG

 

is this in the right place?

Capture 3.JPG

Archicad Solo 24 - 27 : Windows 10 Pro 64-bit : 16 GB ram / Intel Core i7-4770k @ 3.50GHz : NVIDIA GeForce RTX 3060

ok, partly got it working, but not really.  The PDF installation guide didn't say anything about needing to install Python, or was this supposed to be installed with the package?  So downloaded the latest. Now it's saying that it's incompatible:

Capture 4.JPG

 

So I downloaded 3.10.6 version and uninstalled 3.12.2.  and this is the result: 

 I see that it's still trying to read python312 even tho I uninstalled it.

Capture5.JPG

 

what's my next step?

Archicad Solo 24 - 27 : Windows 10 Pro 64-bit : 16 GB ram / Intel Core i7-4770k @ 3.50GHz : NVIDIA GeForce RTX 3060

Hi sknsnw9,

 

Thanks for the screenshots.

 

Python is not needed to run the Add-on. I suspect all of the errors are consequences of the issue shown in the first picture: the 'file ownership' error.

Please unzip the sd.webui folder directly to the C: root folder. Unzipping elsewhere and copying it to the C: root can fail.

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Thank you.  I did extract it twice directly to the C: root folder.  This time, I deleted it and restarted the computer.  Instead of using winrar extract, I dragged it directly to the C: folder.  For whatever reason that seems to work.  Just tested it out, it's now working!

Archicad Solo 24 - 27 : Windows 10 Pro 64-bit : 16 GB ram / Intel Core i7-4770k @ 3.50GHz : NVIDIA GeForce RTX 3060
kylevfa
Booster

Getting a runtime error with a M1 Pro Mac:

"    RuntimeError: MPS backend out of memory (MPS allocated: 16.62 GB, other allocations: 1.49 GB, max allowed: 18.13 GB). Tried to allocate 50.00 MB on private pool. Use PYTORCH_MPS_HIGH_WATERMARK_RATIO=0.0 to disable upper limit for memory allocations (may cause system failure)."

when trying not to run in High VRAM Mode I also get:

"    RuntimeError: "upsample_nearest2d_channels_last" not implemented for 'Half'




Hi kylevfa,

 

It seems that your device runs out of memory. Please close all other apps running in the background and start the engine in lowVRAM. Also using the Add-on right after the device startup can help and it is worth changing the generated picture size as well. 

 

Kind regards,

Norbert Kucsma

Technical Support Engineer

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!