BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Archicad AI Visualizer
Discussions about Archicad AI Visualizer.

ERROR: python3-venv is not installed, aborting


After dragging it to the Terminal window and hit Enter, this message shows up in HomeBrew / Terminal.


I have moved the AI Visualizer folder from Add-ons into Archicad 27 folder > Add-ons > Extra.

And i have moved the sd.webui folder into Archicad 27 folder.


Skjermbilde 2023-11-17 kl. 22.02.39.png


zsh: command not found: python


Obviously, you don't have your Python installation linked to the 'python' executable.


Good night GAG:

I would like to provide you with an update on AI Visualization.

After installing AI Visualization with AC 27, I encountered some problems. Fortunately, the conflicts did not result in any loss of information, but I experienced a persistent showing "gray empty window" when attempting to save a file or module.

AI Visualization appears to be a helpful tool, but I need to learn how to give instructions effectively.

I was advised to uninstall AI, and though I could do without it for a while, the installation process was challenging even with your assistance. Reinstalling would be quite difficult! I'm hopeful that an "installer for dummies" will make a significant difference next time.

As a temporary solution, I opted to quit and wait for 10 minutes to ensure everything was disconnected and memory erased. Upon reopening, I suspected that I wasn't connected to the AI Visualization server, as the "save windows" reappeared correctly.

I am wondering if there is a disable option for AI Visualization so that I can use it only when necessary. It seems what I require is to disconnect from the server.

Please refer to the attached picture, which illustrates the gray empty window at the center of the screen.

Thank you for your assistance.


@iggiv wrote:

<…> but I experienced a persistent showing "gray empty window" when attempting to save a file or module.

iggiv, from your screenshot I can see that the application currently running is indeed Archicad, but I can't identify the empty grey area as the AI Visualizer window, as it doesn't have a caption. Another strange thing is a white area on the left.

Why do you think this is related to the AI Visualizer add-on?




I assume from this I have python3 


Screenshot 2023-11-29 at 9.24.10 am.png

same situation on my system...

@Benh1992 wrote:


I assume from this I have python3 


Ben, now let's see your python3 version:


/usr/local/bin/python3 --version

Looks to be 3.11.6


Screenshot 2023-11-29 at 11.40.51 am.png

I am 90% certain that the problem is related to AI Visualizer, although I may be 100% wrong. Fortunately, everything seems fine now as the issues have disappeared. I am hesitant to replicate the problem because I don't have the option to disconnect from AI> The installation was so difficult I preferred not to UNINSTALL but deactivate until I needed it.
The WHITE RECTANGLE was created by me to hide the WhatsApp conversation that I forgot to close while posting this message.
The GRAY RECTANGLE, as indicated by the red frame in the attachment, from the save window. It remains blank, and I have no option other than pressing the escape button. Consequently, I was unable to save as, or save modules, while the command-S worked.
Despite turning off all of the CI TOOLS, the problem persisted. It was only after turning off the computer that everything returned to normal. I believe this occurred because it disconnected from the AI Visualization server.
The TRACE issue was resolved, although I think it was related to AI. I solved it by resetting the trace mode in the TRACE PANEL.


@Benh1992 wrote:

Looks to be 3.11.6


OK, now we can try to link your 'python3' to be recognised as just 'python'.


First, let's see where python3 points.


ls -la /usr/local/bin/python3


Then we create symbolic link:


ln -s /usr/local/bin/python3 /usr/local/bin/python


After creating symbolic link 'python', test it:


python -c 'import venv; print(dir(venv))'



I have the same problem. I followed the instructions above but unfortunately nothing


Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!