Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Round Edges

Lingwisyer
Virtuoso
Hi all,

Is there a way to have the edge profile of curved objects such as cylinders and spheres drawn in 3D?

I have recently been saving out white model jpegs and curved objects are near impossible to see...




Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200
11 REPLIES 11

Barry Kelly
Moderator
Can you show a sample image of what you mean?

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso

Sketchup example
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Carstenem
Enthusiast
have a go at this effect option, see screen shot.

Cheers Carsten

Barry Kelly
Moderator
I can't make out what the problem is with the 'edge.jpg' image.
But with the 'sketchup' palettes, if the corners of the timber is rounded then you won't see them as sharp edges - as in the lower image.
You will only see the edges as in the top image if the corners are not curved - i.e. a sharp 90° corner (it doesn't have to be 90° - it could be a flat chamfer but you will actually then see two line at that edge).

The curved surfaces blend into adjacent flat surfaces so you won't see an edge.
Only the outer edges of a curve will show where the curve is continuing beyond the angle of view (i.e. you can not see the adjoining flats surface).

Like a sphere, you will see the outer edge (circle) as the surface continues to curve beyond the angle you are viewing it from.
In GDL for PRISMS it is the masking code of 15+64.

All you can do is to convert the model to a morph, then you can select the sub-element edges and make them hard rather than hidden or smooth.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso
If I did a render, you might be able to read the column due to the changes in light across it's face, but alas I am just saving out of the 3D window so there is no progressive shadowing. So you cannot really see the round columns except where they block or cast a shadow.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Carstenem
Enthusiast
what 3D window setting is that you have there ? I tried a lot of the 3D styles and they always show shade ?

Barry Kelly
Moderator
I see the problem - but no solution unfortunately.
Vectorial engine has 'Contours' and 'Silhouettes' that both show.

But when you switch to OpenGL (for white model), then it seems the silhouette lines are now considered as contours - all except the edges of curved surfaces which no longer show at all.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Carstenem
Enthusiast
ah no wow I understand what you are after! Yeah bit of a tricky one.

Carstenem
Enthusiast
that's probably the closest you get, anybody else has an idea ?

Lingwisyer
Virtuoso
Hm, did not consider the vectorial engine. With monochrome active, it should be acceptable for my current use.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Hi ling,

Did you try to add a second view on your layout to have :
- one 3d traditional view
upper
- one document 3D view with the same POV
Christophe - FRANCE
Archicad Designer and Teacher
Archicad 15 to 24 FRA FULL
OS 11 Big Sur

"Quality is never an accident; it's always the result of an intelligent effort " - John Ruskin

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!