cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Image Fill PNG Transparency

crws
Participant

Hi everyone, this is my first time posting so please forgive me if this is off-track!

 

I'm hoping to use some custom image fills I have drawn in Archicad. They are scanned pngs which have been made transparent for overlaying over each other. They work successfully in Illustrator. This transparency isn't present when imported into Archicad as an Image Fill. 

 

Is there something I need to do to achieve the results as in Illustrator, or is this not a supported function?


Cheers!

Archicad 25. Windows 10. Intel 9900k, 64 GB RAM, AMD Vega 64.
6 REPLIES 6

Botonis
Enthusiast

If you are using Archicad 25 and forward you can use a fill set as Surface-Cover Fill.

Instead of a fill create a material with the png and set it in the fill selection settings.

Check the photo for settings. 

For fill background set the transparent option to enable the transparency channel of png. 

 

I do not remember if surface cover fill existed before 25.......

 

Archicad 25-26. Windows 11. Intel Xeon 2680x2,64 GB RAM, Nvidia 3080Ti-Titan X Pascal. 2 Monitors.

Thanks for your reply Botonis! I have managed to get the png to function with the Surface - Texture Fill, but not when using Surface - Cover Fill. However, there is still no transparency using the Surface - Texture Fill option. 

 

This also doesn't appear to function with a transparent png texture that is built in. I assume transparency works in the same way as it does in 3D where there are issues with multiple overlaid transparent objects.

Archicad 25. Windows 10. Intel 9900k, 64 GB RAM, AMD Vega 64.

Botonis
Enthusiast

Can you check whether your fill background setting is set to transparent?

Also check if you have set any override that alters the fill settings.

If you are using the fill in sections/elevations you must enable the transparency in the sections settings.

Check the video.

Archicad 25-26. Windows 11. Intel Xeon 2680x2,64 GB RAM, Nvidia 3080Ti-Titan X Pascal. 2 Monitors.

Hi Botonis,

 

The issue isn't with the cover/vector fills but with the image fills. Transparency is working fine with the vector fill. It is the same result with the drafting fills or surface (cover fills).

crws_0-1661502696554.png

 

Archicad 25. Windows 10. Intel 9900k, 64 GB RAM, AMD Vega 64.

Botonis
Enthusiast

In the video I am using a fill that also has a vector setting in the fill settings so that is why it enables the transparency option. You are right about image fills. The only fast workaround I can think off is import the png directly and enable the transparency but this will meen loosing the fill capabilities and you will also need to scale the photo correctly according to your needs. But I am sure you already have thought also this solution......!! 

Archicad 25-26. Windows 11. Intel Xeon 2680x2,64 GB RAM, Nvidia 3080Ti-Titan X Pascal. 2 Monitors.

Hello and thank you again for your assistance on this matter Botonis! 

 

I have given up on this for now as there are more pressing matters to attend to, but it would be cool if Graphisoft could consider such a possibilty. I imagine it would be quite taxing on a project's load, but it is a great effect and would be great to have the option!

Archicad 25. Windows 10. Intel 9900k, 64 GB RAM, AMD Vega 64.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!