About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Archicad crashes when I'm trying to publish Layout with textured section?


Hey guys!
So I'm trying to publish a Layout with a section and every time I have the textures activated on the section and not just color textures Archicad crashes while publishing. I tried to use different textures because I thought maybe a custom texture from me is causing it but no difference. I can only use color textures with no crashing.

Anyone has any ideas what I'm doing wrong?


Have you tried closing the file and opening it again from within Archicad using the File> Open menu but selecting open and repair form the options. That process often fixes a lot of peculiar issues like this.

Lee Hankins
ArchiCAD 4.5 - Archicad 27UKI Apple Silicon 5003
macOS Ventura (13.5.2)

Benjamin Dani



I'm sorry to hear that you experience crashes!
May I ask you what Archicad version are you using? Is it Archicad 25 build 50xx by any chance?
If yes, according to your description I'm suspicious that this is a known issue.
This crash is caused when the file has any shell which uses surfaces without textures. It can be caused by deleted surface textures or surfaces that do not have textures by default (e.g.: Painting surfaces).
The crash could be avoided by following these steps:
1 - Do not delete surfaces before publishing;
2 - Replace the missing textures;
3 - Check if any surface called "Paint - ..." is used, then set another one with texture instead.


If it is not the Archicad version you are using and these steps are not helping I suggest reaching out to your local support with the description of the issue. Please also send them the bugID which pops up in the bug reporter application after the crash.


Kind regards,

Dani Benjamin
Technical Support Engineer


I'm having a similar issue, but mine is crashing when I am clicking on "page setup". I'm using 26 and just reinstalled and reloaded all the updates. 

@AandR wrote:

I'm having a similar issue, but mine is crashing when I am clicking on "page setup". I'm using 26 and just reinstalled and reloaded all the updates. 

Similar only in that Archicad is crashing.

The cause is nothing alike.

You problem is similar to this ...


Maybe check your printer drivers.


I am assuming you are using Mac Ventura as well.

It is a good idea to add information about you machine and operating system, especially when you are talking about Archicad crashing.





One of the forum moderators.
Versions 6.5 to 26
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

I do have Mac Ventura


I just had printer drivers updated on my computer a few weeks back so they are up to date. This issue didn't start for me personally until I updated to the latest Build. I have the Graphisoft team working on my computer today remotely, hopefully they will discover the issue. 


I will report back on here what they found just in case it is useful to anyone else. 

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!