Got a minute? We appreciate your feedback:

Graphisoft Learn survey
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Glitch when publishing to PDF or BimX

I have a problem when attempting to publish my drawing in ArchiCAD 24. In the published document, for some reason it has changed the scale in my drawing from 1:100 to 1:200 and bunched up all my dimensions into an unreadable mess. This happens both when publishing to PDF and when publishing to BimX. This is very frustrating. Has anyone else has this problem, and how was it solved?
AC24 Australia | Windows 10 64 bit | IC3D Workstation, 64GB RAM, 4.9GHz i9 core

Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni

Thank you very much for the report and I am very sorry about the issue!

To investigate further, could you share with us the problematic file in PLA format for in-house testing? Please let me know if you'll need a secure place to upload the file.

Also, is it happening even with a brand new file, or with one particular file only?

Looking forward to hearing from you!

Best regards,

Minh Nguyen
Technical Support Engineer

I could do that, but I've actually sorted it out now, although I had to individually change each drawing's scale in the drawings settings in the layout book. Turns out that though it was showing the correct scale in the view map, it had changed scale in the layout book. I also had to rearrange the dimensions manually in the layout book. This all took a bit of extra time and I'm not sure it should have happened, but I've sorted it. Thanks for replying

AC24 Australia | Windows 10 64 bit | IC3D Workstation, 64GB RAM, 4.9GHz i9 core

Barry Kelly
Mimsy wrote:
I also had to rearrange the dimensions manually in the layout book.

Are you really dimensioning in the layout book?
Not that you can't do this, but I wouldn't.

Do your dimensions (in fact all annotation) in Archicad at the scale that you intend to produce the drawing for that view.
If you want, you can have multiple layers for annotation at different scales as it will appear to move or resize at different scales - so you annotate to suit each scale.
Save a view for each scale and make sure the correct annotation layers are on - you do this by creating layer combinations for each scale.
The scale and layer combination is saved with the view (which you can change f you ever need to).

Now you place the drawing of the view on the layout - it will have the correct scale and annotation - you just have to place it where you want and crop if needed.
Nothing to worry about when you publish - what you see in the layout is what you will get.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!