Installation & update
About program installation and update, hardware, operating systems, setup, etc.

4K Monitor with MacBook Pro M2 (2023), 2D and 3D lagging

Vinicius Lima
Booster

Hello guys,
Bought a new Dell Ultrasharp 4K 27" to use with my 2023 Macbook Pro M2. They are connected by an USB-C cable.
Everything is sharp and clear, no 2D/3D antialiasing problems. But... To orbit in 3D window, and to drag (pan) in 2D window, Archicad image is lagging/glitch a lot. Tried many resolutions, but still lags/glitches like a strobe light.
Using just the Macbook Pro screen (without the monitor) everything works smoothly. Any thought?

- Vinícius Lima - user since Archicad 12
from Brazil
Apple MacBook Pro 16" 2023 | M2 Pro | 16Gb RAM | macOS Ventura 13.5.2
1 ACCEPTED SOLUTION
5 REPLIES 5
Solution
Vinicius Lima
Booster

After a few weeks of tests, it appears that restarting Archicad resolves the issue. (what is weird, but...)

- Vinícius Lima - user since Archicad 12
from Brazil
Apple MacBook Pro 16" 2023 | M2 Pro | 16Gb RAM | macOS Ventura 13.5.2

@Vinicius Lima wrote:

After a few weeks of tests, it appears that restarting Archicad resolves the issue. (what is weird, but...)


You mean you haven't restarted Archicad in a few weeks?

Which would also mean you have not been re-starting your machine?

 

I would recommend shutting the machine down at the end of each day.

I know it means you have to wait for everything to start up again the next day, but from a computer health point, it is a good idea to restart at least once a week.

I don't actually shut down my machine, but I do close all applications and log out at the end of each day.

Then I don't have to wait for the machine to start up, just the programs I need.

 

 

At least restart Archicad when ever the opportunity arises.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Hi Barry!
I do restarts Archicad every day. The machine, I do not restarts with any routine, just when OS or apps asks updates. Still, I found this Apple forum topic with this "restart" related theme for your (and others) appreciation:

 

https://discussions.apple.com/thread/253648533

 

Apple MacBook Pro 16" 2023 | M2 Pro
16Gb RAM
macOS Ventura 13.5.2 

- Vinícius Lima - user since Archicad 12
from Brazil
Apple MacBook Pro 16" 2023 | M2 Pro | 16Gb RAM | macOS Ventura 13.5.2
Karl Ottenstein
Moderator

I have pretty much the same setup, with the Dell U2723QE set as the Mac's primary monitor when plugged in.  I had a similar problem when I first got the monitor, and the solution for me was to change the speed prioritization in the monitor menu settings.  If yours is like mine, there is a little joystick like thing on the back towards the lower right.  Otherwise, the menus are likely similar, Dell being Dell...  Press the joystick to go into the menus, then arrow down to the Display settings...then arrow right and through that menu to select "USB-C Prioritization".  Set that to "High Speed Data" (the problem happens when that is set to "High Resolution").

 

See if that doesn't resolve things for you?  If not, it isn't an Archicad issue, but a Dell/Mac issue and you'll find online forums with people with Macs discussing issues such as this.

 

BTW, I have my U2723QE set in Display preferences to scale to 2560x1440 which works well in Archicad with my elderly eyes.  Disappointingly, this will show as a refresh rate of only 30 Hertz.

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Hello Karl, thanks for your answer!
But my setup its working well since I answered the topic above. When I was trying to fix the problem, I found this option "High Speed Data" prioritization in the monitor menu as well, and set it just as you said. By the way, my monitor is exactly the same of yours (U2723QE). Using 3008x1962 with 60Hz, and its working smootly. Maybe I've changed to much settings, and the Archicad was only able to work fine when I restarted it.
PS: I tried to put on 2560x1440 resolution, with refresh rate of 60Hz, and it's avaible for me, and works fine too. Double-check it  (take a look on the print-screen attached).
Well, good thoughts guys. Thanks a lot!

- Vinícius Lima - user since Archicad 12
from Brazil
Apple MacBook Pro 16" 2023 | M2 Pro | 16Gb RAM | macOS Ventura 13.5.2

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!