Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Archicad 13 installation problem

Anonymous
Not applicable
Hello guys , i tried to install AC 13 for mac several times now but when the installer run a message ARCHICAD 13 cannot be installed on this platform.

I have read that maybe the installer was not for Intel mac and downloaded another one for Intel but again i have the same problem.

I have download the installer from myarchicad website.

Anyone can help me on this please ?

Alexandros
12 REPLIES 12
Laszlo Nagy
Community Admin
Community Admin
Maybe you have an old Mac or old operating system and that is why.
Check the specifications of your computer against the hardware requirements:

http://www.graphisoft.com/support/archicad/system_requirements/
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Anonymous
Not applicable
my i MAc is 10.6.2.
Laszlo Nagy
Community Admin
Community Admin
Can you post the screenshot with the exact error message?
I don't have a Mac, but someone who does may have an idea.
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Anonymous
Not applicable
This is a screen shot with the error message
Laszlo Nagy
Community Admin
Community Admin
I cannot read the error message, the screenshot is not large enough.
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Karl Ottenstein
Moderator
I could read it (maybe because I knew what it was supposed to say)... 😉

The error message is indeed the one that displays if attempting to install on a PPC, but your About box clearly shows an Intel processor.

You might have to contact tech support... something unusual is going on...

Karl
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Karl Ottenstein
Moderator
There might be something odd about your account settings / loaded extensions / etc.

Try setting up a fresh admin account, log into that and try installing. If that doesn't work, restart in Safe mode and try to install there.

Karl
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB
Anonymous
Not applicable
i have downloaded the education version 10 times now, from different locations ( country locations from my archicad) , i have repaired my os x 2 times and still the same thing i can't understand why , i sent email to two different country support of graphisoft ( greece and uk ) and they didn't gave a straight answer yet i don't know what to do . And i am thinking if i buy the normal version not trial would i have the same problem, is the same installation ?
Karl Ottenstein
Moderator
alexandros27 wrote:
i have downloaded the education version 10 times now, from different locations ( country locations from my archicad) , i have repaired my os x 2 times and still the same thing i can't understand why , i sent email to two different country support of graphisoft ( greece and uk ) and they didn't gave a straight answer yet i don't know what to do . And i am thinking if i buy the normal version not trial would i have the same problem, is the same installation ?
The EDU version has a different licensing procedure; don't know if it is a different installation.

I do not recall hearing of anyone running into this problem before - only reports I remember of this message were people with PPC Macs.

You didn't set your Mac to start up in 32 bit mode (rather than the default 64) by any chance? Or do any other customization? Is your Java up to date?

Did you try my suggestion of restarting your Mac in Safe mode? And/or creating another admin account and installing there?

Karl
One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.7, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB