Choose your top Archicad wishes!

Read more
Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Cant open .pln files automatically with Archicad 27


When I try to open a .pln file, which is a version 27 Archicad file, but it still tries to open the file with Archicad 26. I couldn't find any way to change the default app for the .pln file to Archicad 27. It also doesn't show up in settings of Windows 11.


Operating system used: Windows 11

Barry Kelly

You can right click o the file and chose 'Open With' and browse for Archicad 27 program file.

Sometimes it will give you the option to always associate with that program.


Or go into the Archicad Program folder.

In there look for a folder called "Graphisoft Shell Extension".

In there will be a "Register.bat" file.

Double click that to run it and it should now associate .PLN with Archicad 27.

You may have to restart your computer to take affect.



One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Setup info provided by author