BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Keyboard shortcuts problem

Takis
Expert
Hi I work with Archicad 19 and I have a problem with keyboard shortcuts which occurs when I forget to switch my keyboard Language to English.

So if I press Ctrl+Shift+D to drag a copy while the active language is "Greek" is not working.

Switching back to English Language keyboard shortcuts are not working and needs an Archicad restart to make it working again.

MacPro Late 2013
Apple keyboard
Windows 10 x64
10 REPLIES 10
Laszlo Nagy
Community Admin
Community Admin
Do you really actually use two keyboard layouts? I means, switch to one in some programs, switch to the other in others?
I have a HUngarian keyboard on my laptop so after a while I figured: why do I have an English keyboard layout installed when my keyboard is Hungarian? It just adds confusion. The only reason it was there (the English) is because I have an English version of Windows and it installs it by default. So I just uninstalled the English, left the Hungarian and there is no issues coming from keyboard layout switching.
Something to consider if this matches your situation.
Loving Archicad since 1995 - Find Archicad Tips at x.com/laszlonagy
AMD Ryzen9 5900X CPU, 64 GB RAM 3600 MHz, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), Windows 10 PRO ENG, Ac20-Ac27
Takis
Expert
Hi, yes I have two languages installed because the most of my programs work in English and I have to write in Greek also.

For example in Archicad I use english for the kyeboard shortcuts but when I work on a project the text of the project notes has to be in Greek language.

Nevertheless I believe that this shouldn't affect Archicad's shortcuts.
Anonymous
Not applicable
I am facing the same problem.but it doesn't appear everytime i switch from greek to english but after a little while or maybe more. I have A18 English version and surely i want to be able to write text in greek . While returning keyboard into english lets me use the wasd keys for flying mode, the shortcuts like ctrl+t and all the others dont work (even the simple ones like pressing m for measuring a distance.
The strange thing is that it is not happening after i toggle from english to greek and back once or twice so i am not even sure if its related to the second keyboard layout we have
Maybe Takis have you found a solution?
Takis
Expert
Hi, yes the solution that I use and works is to reload your profile:

Options --> Work Environment --> choose your profile and click apply.

The above procedure works only for this kind of problem i.e keyboard shortcuts are not responding.

Takis
Anonymous
Not applicable
Sir Takis huge respect
i was a little late to respond to your fast reply cause i havent actually made a custom profile for myself (i wasnt sure what and where to reload) so i only had to reload the standard profile .
and yes everything worked as normal (shortcuts ad stuff)
Anonymous
Not applicable
the complete solution -works perfectly- as a member of archicad technical support team gave it to me :
Apparently by default AC shortcuts are set up to take the characters into account instead of the keyboards button when you press a shortcut combo.
And because of this when you use the GRE input language, you press Ctrl+Shift+delta, instead of Ctrl+Shift+D and that is why the "Drag a copy" does not work.

The good news is that you can change this setting in the registry keys.
- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 19.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Now AC will take the keyboard button pressed down disregarding the actual input character.
Anonymous
Not applicable
grand106 wrote:

The good news is that you can change this setting in the registry keys.
- Open "Regedit" in the Windows start menu
- Navigate to HKEY_CURRENT_USER\SOFTWARE\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 19.0.0 INT R1\KeyMode Shortcuts registry key and change the value of it from 0 to 1

Now AC will take the keyboard button pressed down disregarding the actual input character.
that worked perfectly for me, Thanks a lot
Anonymous
Not applicable
I had the same problem and finally it was solved when i reapply the profile as mr. Takis said. Tanks A lot
Anonymous
Not applicable
This was a crucial problem.
Solved with the above registry editing.
thanks.
Learn and get certified!