cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Installation & update
About program installation and update, hardware, operating systems, setup, etc.
SOLVED!

OpenGL version and GPU support

ananas
Advocate

Hii!

 

After udpating Archicad to ver 25, open GL doesn´t work anymore. I can only see 3D in vector mode,  which is for my laptop (with GPU MX150) of course too much to handle.

 

How can I check which OpenGL version Archicad 25 use and if GPU MX150 supports it?

 

Thank you for help!

1 ACCEPTED SOLUTION

Accepted Solutions
Solution
Miha_M
Advisor

This GPU does support opengl 4.5. Did you try to update the GPU drivers?

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

View solution in original post

9 REPLIES 9
Barry Kelly
Moderator

You require OpenGL 4.5

System requirements for 25 can be found here ...

 

https://graphisoft.com/resources-and-support/system-requirements-25

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Solution
Miha_M
Advisor

This GPU does support opengl 4.5. Did you try to update the GPU drivers?

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11

Hii! They are up to date! but after the third restart everything started working again hah 🙂

ananas
Advocate

Hi!

 

I have again problems with open GL, this time on AMD GPU, which is up to date.

OpenGL is simply not available in any version of Archicad.

 

Windows 11 and Archicad 23 / 25 are installed (both versions have openGL issues).

 

Anyone knows how to troubleshoot further? 🙂

 

 

 

 

 

 

 

 

 


amd GPU.pngdevice manager.pngopen GL.pngopen GL viewer.png
Lingwisyer
Guru

Have you tried disabling the onboard GPU to ensure that AC is using the dedicated?

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660

If you mean disabling Intel UHD integrated GPU in Task manager. I did that, but I still dont see openGL option in Archicad. Only this vectorial 3D view, which is slow.

 

I mean idk, it could be something with this AMD GPU and wrong settings also.

I had this Open GL issue before on a laptop with MX150 GPU and it just started working again at some point with no reason.

 

AMD GPU looks like needs some extra help 😄

I can see the driver version is back to April 2022 so you may really need to check for updated driver.

EDIT: Sorry @Lingwisyer  I reply to @ananas.

AC 27 INT 5030/WIN 11
AMD Ryzen 7 5800H with Radeon Graphics 3.20 GHz 16.0 GB

Hi!

 

Non of the latest driver works... Here I guess i did a printscreen with one of the old drivers (I tried over 10 of them). So far non of them work.

 

The only guess I have now is that some AMD settings are not right. But I do not know which ones

You need to disable the integrated GPU in another way, killing a process in the task manager won't work. Take a look here: Disabling Onboard Video to Add Video Card (intel.com)

| Archicad 4.55 - 27
| HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Quadro M5000 | Windows 10 Pro x64
| HP Z4 G4 | W-2245 | 64 GB RAM | RTX A4000 | Windows 11