BIM Coordinator Program (INT) April 22, 2024
Find the next step in your career as a Graphisoft Certified BIM Coordinator!
Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

Missing Accessories in 3D with MVO Settings Turned On


Hello everyone, I'm not sure what's going on but my knobs for my cabinets are not showing in 3D. Knobs are turned on with materials set, the 3D Detail Level of the cabinets is set to MVO, and the MVO settings for my 3D View are set to show all accessories, but they're not showing in 3D. Is there another setting somewhere I'm missing? Even if I set the 3D Detail Level for individual cabinets to Full they still do not show.




Screenshot 2022-12-15 090338.jpg

Screenshot 2022-12-15 090407.jpg

Screenshot 2022-12-15 090242.jpg

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT

Accepted Solutions


Your template/file is corrupt.

It does not pass the value in the Model view option to the object, but it does store it.

I change the following library parts to work out where the error was.






the 0 is the "hide knobs value"




this shows a 1 for hide, but the stored value is a 0



when it is turned off it shows the 1.


this is a problem in the file, probably because you upgraded from an earlier version to AC24 rather than building from scratch.

if you open the file in 25 it fixes it.

you can then save the file down to 24, and the fix stays.


see attached file which was upgraded to 25 then saved down to 24.

if you save it down to 23 then open in 24 then the error reappears.

I hope your BIM Manager fixes the template.(or updates the Library so the knobs show up)


I have been using ArchiCAD continually since ArchiCAD 4.5, 4.5.5, 5, 5.1, 6, 6.5, 7, 8, 8.1, 9, 10, 11, 12, 13, 15, 18, 21, 22, 25, now testing 27
Member of Architalk since 2003, but missed the migration to Graphisoft.
(where have all my original posts gone?)

View solution in original post




archicad model view.png

Yes I checked that, everything seems to be set up correctly but I'm still not getting knobs to show up.


Screenshot 2022-12-15 134742.jpg

Screenshot 2022-12-15 134830.jpg

Screenshot 2022-12-15 134908.jpg

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT

can you send me a pln with that single cabinet ?


Hello @ocamorlinga ,


What happens if you turn that setting off in the MVO ?

I believe in earlier AC, that option was hiding handles when that icon was ON but it switched to showing it at some point. There may be some conflict there.

With the setting turned off or on, the knobs don't show in 3D

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT

Attached is a pln with the default cabinet from the A24 library, and our slightly modified cabinet. Both are not showing knobs in 3D, the MVO settings are turned on and both objects have their 3D Detail Level set to MVO, although even if I switch it to Full, it doesn't show the knobs.

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT

I think i found it:
I did the following: I opened your drawing,
show 2d (F2)
select the 2 objects
press F5
select the two 3d objects and go to attributes
switch from MVO to Fullchange MVO to Full.jpg

I did as you suggested, but the knobs are still not showing up.




I really appreciate your help! Could it be a Work Environment setting?

AC 24 US
Windows 10, AMD Ryzen 7 3700X, 16.0 GB Ram, AMD Radeon RX 5700 XT

I think looks more like a libraries problem in the web server , because when I copy paste the object to a new fresh open Archicad window, it show complet


same objects copy paste in a new clean archicad sesion.jpg
Learn and get certified!